Bienvenue aux nouveaux arrivants sur FantasPic !

- Pensez à lire les règles durant votre visite, il n'y en a pas beaucoup, mais encore faut-il les respecter .
- N’hésitez pas à faire des remarques et/ou suggestions sur le Forum, dans le but de l'améliorer et de rendre vos prochaines visites plus agréables.
- Vous pouvez regarder votre "panneau de l'utilisateur" afin de configurer vos préférences.
- Un passage par "l'utilisation du forum" est recommandé pour connaître les fonctionnalités du forum.

--- L’équipe FantasPic ---
Forum général sur l'Assembleur !

Modérateur : mazertoc

Led RGB 5050 WS2812B
paulfjujo
Avatar de l’utilisateur
Expert
Expert
Messages : 2026
Âge : 71
Enregistré en : juillet 2015
Localisation : 01800
Contact :

#71 Message par paulfjujo » dim. 14 juin 2020 09:44

Bonjour Venom, et à tous

Idem la meme chose ....
par contre en ouvrant l'onglet Graph, verification j'ai une error !

beaucoup plus de composants que sur le schema ?
meme si je nettoie avec la commande "Tidy" pour ne garder que les composants du schema , c'est pareil

Proteus_WS2812_Problemo_a.jpg



j'ai l'impression que ce projet ne peut pas marcher avec la version d'essai
qui ne marche qu'AVEC les projets proposés en test, et non pas, ceux crées ou modifiés par l'utilisateur.
je vais donc laisser tomber..proteus
et racheter des WS2812 (ou un anneau 60 leds) pour de VRAI ..


Nota : j'ai toujours mon vieux ISIS de 2008 pour creer des schémas !
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.
Aides toi, le ciel ou FantasPic t'aideras

Led RGB 5050 WS2812B
Temps-x
Avatar de l’utilisateur
Expert
Expert
Messages : 2027
Enregistré en : juillet 2016
Localisation : Terre

#72 Message par Temps-x » dim. 14 juin 2020 12:28

Bonjour paulfjujo, venom, et tout le forum,

Excusé pour le retard de ma réponse,

paulfjujo a écrit :Source du message C'est avec une version d'essai que tu l'as testé ?


:roll: ben, non.... :sifflotte:

paulfjujo a écrit :Source du message j'ai l'impression que ce projet ne peut pas marcher avec la version d'essai


Tout les schémas que je fais avec Proteus, je l'ai fait à partir d'un ordinateur qui avait été jeté, j'ai réparé celui-ci, puis j'ai vu cette version.
qui était fonctionnelle sur son disque dur.

Je ne pensée pas qu'il allé bridé les essais à ce niveau là !! , je vais modifier les posts....

Je vais voir du coté de MicroCap 12 si c'est possible, pour que tout le monde puisse en profiter.

Merci ! du retour

==> A+
Modifié en dernier par Temps-x le dim. 14 juin 2020 14:03, modifié 3 fois.
:roll: Les requins, c'est comme le langage ASM, c'est le sommet de la chaîne alimentaire. :wink:

Led RGB 5050 WS2812B
venom
Avatar de l’utilisateur
Confirmé
Confirmé
Messages : 928
Âge : 36
Enregistré en : avril 2016
Localisation : Klyntar
Contact :

#73 Message par venom » dim. 14 juin 2020 12:44

paulfjujo a écrit :j'ai l'impression que ce projet ne peut pas marcher avec la version d'essai
qui ne marche qu'AVEC les projets proposés en test, et non pas, ceux crées ou modifiés par l'utilisateur.
je vais donc laisser tomber..proteus


C'est probable mais dommage.




@++
Mon site web
Mon discord : venom#4888

Led RGB 5050 WS2812B
paulfjujo
Avatar de l’utilisateur
Expert
Expert
Messages : 2026
Âge : 71
Enregistré en : juillet 2015
Localisation : 01800
Contact :

#74 Message par paulfjujo » dim. 19 sept. 2021 21:12

bonsoir à tous,

je reviens sur ce fil pour vous aviser de mes deboires avec un ruban 60 leds RGB WS2812E sur 1 Metre...
destiné à une horloge diametre 31cm ... 1/PI

au premier test : 2 leds allumées en permanence avec la ligne data au 0V !
apres 2 à 3minutes , 6 leds crament ..fumée !
alim de 4.8V ( en dessous du max 5V)

A priori,c'est deja arrivé à d'autres utilisateurs !
le modele E (economique ) est à proscrire ..
les leds n'ont AUCUN marquage .
Je viens découper le ruban pour essayer d'en récuperer quelques unes qui , à la loupe, semble encore OK ..
en test dès demain ..
Aides toi, le ciel ou FantasPic t'aideras

Led RGB 5050 WS2812B
Temps-x
Avatar de l’utilisateur
Expert
Expert
Messages : 2027
Enregistré en : juillet 2016
Localisation : Terre

#75 Message par Temps-x » dim. 19 sept. 2021 23:25

Bonsoir paulfjujo, et tout le forum,

paulfjujo a écrit :Source du message apres 2 à 3minutes , 6 leds crament ..fumée !

Merci ! pour le retour d'information, vraiment pas bon cette RGB WS2812E, j'espère que j'aurais pas le même problème avec les RGB WS2812B quand je vais mettre en fonction mon montage.

Il faut ajouter que ses RGB WS2812 son très sensible à la chaleur, si vous en souder, prenez de la soudure à base tempèrature et si votre fer à soudé est réglable en tempèrature régler au plus bas de la fusion de votre soudure.

==> A+
:roll: Les requins, c'est comme le langage ASM, c'est le sommet de la chaîne alimentaire. :wink:

Led RGB 5050 WS2812B
paulfjujo
Avatar de l’utilisateur
Expert
Expert
Messages : 2026
Âge : 71
Enregistré en : juillet 2015
Localisation : 01800
Contact :

#76 Message par paulfjujo » lun. 20 sept. 2021 15:21

bonjour,

sur mon ruban de 1M 60led, je n'ai pu récupérer qu'un morceau de 7 leds contigües !!!
les autres sont soit cramée, soit ont la pin DIN en court-jus avec le Gnd , ou la traversée DIN coupée !
un petit point noir de trop sur la led (point de jonction petit fil interne) => led HS
WS2812E_Problemo_2021-0920.jpg


j'ai donc refait ce montage de test
Alim commune MCU et Leds ,mais 1000µF aux bornes 4.8V DC
1 R de 10K entre Entree DIN ruban et Gnd (fixe le potentiel au 0V , sans commande via le PIC
La sortie RC5 pilote le (bout de ) ruban.
:sifflotte: comportement conforme ... :furieux: à 53 leds absentes près!

Test_morceau_ruban_led_WS2812E_2021-0920.jpg


video ICI

nota : toutes les leds etaient déja soudées sur le ruban

une explication sur cette problematique:

WS2812B_versus_WS2812E_RGB_Leds.jpg
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.
Aides toi, le ciel ou FantasPic t'aideras

Led RGB 5050 WS2812B
paulfjujo
Avatar de l’utilisateur
Expert
Expert
Messages : 2026
Âge : 71
Enregistré en : juillet 2015
Localisation : 01800
Contact :

#77 Message par paulfjujo » lun. 25 oct. 2021 16:07

bonjour à tous,


Je reviens ici sur ce post
car j'ai reçu mon nouveau ruban 60 leds 1Metre équipé de Leds RGB WS2815 en 12V DC
* ce ruban fonctionne aussi en 5V DC ! ( avec moins de luminosité bien sur !..)
Testé en meme temps que
20 leds RBG unitaire WS2812B
et mon ancien morceau de ruban avec WS28212E
les 3 sur la meme cde PIC18F27K42 RC5
oo ps les couleurs sont differentes sur le ruban WS2815 !!!

apres des recherches sur le WEB , ou on ne parle principalement que de la tension d'alim 12V ou 5V
j'ai pu quand trouver POURQUOI !

idea ! il y a 2 version de WS2815 !
la version WS2815 ECO qui est en RGB ( et moins fiable, et leds moins puissantes)
et la version WS2815 qui est en GBR (et qui a des connections internes en fil d'or, plus grande longvité )
en regardant la led à la loupe , j'ai bien une version OR ..( :-D pour une fois, je ne me suis pas fait avoir)
CQFD ...

donc ACHTUNG !
exit

à Temps-X .. mes leds WS2812B on un diametre externe de 9,6mm et la led elle meme ne fait que 4mm de diametre. (meme format que sur les rubans)
quelles sont tes dimensions de leds ?
Aides toi, le ciel ou FantasPic t'aideras

Led RGB 5050 WS2812B
Temps-x
Avatar de l’utilisateur
Expert
Expert
Messages : 2027
Enregistré en : juillet 2016
Localisation : Terre

#78 Message par Temps-x » mar. 26 oct. 2021 00:22

Bonjour paulfjujo, et tout le forum,

paulfjujo a écrit :Source du message quelles sont tes dimensions de leds ?

WS2812B (mesure).JPG


paulfjujo a écrit :Source du message j'ai bien une version OR .

Alors moi aussi 8-)

==> A+
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.
:roll: Les requins, c'est comme le langage ASM, c'est le sommet de la chaîne alimentaire. :wink:

Led RGB 5050 WS2812B
paulfjujo
Avatar de l’utilisateur
Expert
Expert
Messages : 2026
Âge : 71
Enregistré en : juillet 2015
Localisation : 01800
Contact :

#79 Message par paulfjujo » mar. 26 oct. 2021 09:15

bonjour Temps-X et à tous,

merçi,
sur la photo de ton test elles me paraiassait plus grandes .. peut etre parce qu'elles sont soudées avec un espace inter-led ..
on a donc quasiment les memes , les miennes en fond noir ..
Aides toi, le ciel ou FantasPic t'aideras

Led RGB 5050 WS2812B
Temps-x
Avatar de l’utilisateur
Expert
Expert
Messages : 2027
Enregistré en : juillet 2016
Localisation : Terre

#80 Message par Temps-x » mer. 27 oct. 2021 01:02

Bonsoir paulfjujo, et tout le forum,

paulfjujo a écrit :Source du message les miennes en fond noir ..

Une fois allumée on ne vois pas la différence, comme je sais que c'est de l'or, je les garderaient même quand ils fonctionneront plus, comme c'est partie actuellement, d'ici quelle que année ça faudra une fortune :-D

==> A+
:roll: Les requins, c'est comme le langage ASM, c'est le sommet de la chaîne alimentaire. :wink:


Retourner vers « Langage ASM »

Qui est en ligne

Utilisateurs parcourant ce forum : Bing [Bot] et 7 invités