Bienvenue aux nouveaux arrivants sur FantasPic !

- Pensez à lire les règles durant votre visite, il n'y en a pas beaucoup, mais encore faut-il les respecter .
- N’hésitez pas à faire des remarques et/ou suggestions sur le Forum, dans le but de l'améliorer et de rendre vos prochaines visites plus agréables.
- Vous pouvez regarder votre "panneau de l'utilisateur" afin de configurer vos préférences.
- Un passage par "l'utilisation du forum" est recommandé pour connaître les fonctionnalités du forum.

--- L’équipe FantasPic ---
Forum général sur le langage C !

Modérateur : Jérémy

PIC16F88 ne démarre pas
lake
Membre
Membre
Messages : 5
Enregistré en : octobre 2018

#1 Message par lake » mar. 9 oct. 2018 15:51

Bonjour à tous !
Premier post :)

J'ai comme projet de digitaliser des vieux trains jouefs et j'ai un petit soucis avec des PIC16F88.
J'en ai plusieurs en stock et donc je me suis dit pourquoi pas les utiliser comme décodeur dans les locos.

Le problème est simple : ils ne démarrent pas. J'utilise un 5V externe propre bien régulé et un Pickit3 pour programmer.
J'utilise bien d'autres bien sans problèmes, peut être ceux-ci sont morts ?

Un screen vaut mieux qu'un long discours, avec un programme bateau.
g4vudmhw.jpg


Merci d'avance pour l'aide :)
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.

PIC16F88 ne démarre pas
Jérémy
Administrateur du site
Administrateur du site
Messages : 2121
Âge : 39
Enregistré en : juillet 2015
Localisation : Dans le sud
Contact :

#2 Message par Jérémy » mar. 9 oct. 2018 16:34

Bonjour lake et bienvenue sur FantasPIC !

Je suis surpris de voir une interface d'IDE MikroC de mikroelekronika avec l'utilisation d'un PICKIT3 de microchip ?
Tu te sers du .hex de mikroC ?
C'est en faisant des erreurs, que l'on apprend le mieux !!!

PIC16F88 ne démarre pas
Temps-x
Avatar de l’utilisateur
Confirmé
Confirmé
Messages : 894
Enregistré en : juillet 2016
Localisation : Terre

#3 Message par Temps-x » mar. 9 oct. 2018 18:02

Bonjour lake, et tout le forum,

Soit le bienvenue sur le forum, et espère que tu passeras des moments formidables avec nous tous. :wink:

la première chose à faire, c'est de faire clignoter une LED, tu peux trouver ICI un exemple en version ASM, avec fichier compiler + source + plan, et une explication.

Le 16F88 à la peau dur, avant de le tuer il faut vraiment faire une fausse manœuvre, c'est un de mes Pic préféré.

==> A+
Modifié en dernier par Temps-x le mar. 9 oct. 2018 18:03, modifié 1 fois.
Quand la souris nargue le chat, c'est que son trou n'est pas loin.

PIC16F88 ne démarre pas
lake
Membre
Membre
Messages : 5
Enregistré en : octobre 2018

#4 Message par lake » mar. 9 oct. 2018 18:03

Oui je précède comme cela depuis un moment, ça marche assez bien. Je me sers pas mal du dernier pin du pickit pour faire de l'analyse logique (petit "addon" compris dans le "Pickit3 Programmer").

Temps-x a écrit :Bonjour lake, et tout le forum,

Soit le bienvenue sur le forum, et espère que tu passeras des moments formidables avec nous tous. :wink:

la première chose à faire, c'est de faire clignoter une LED, tu peux trouver ICI un exemple en version ASM, avec fichier compiler + source + plan, et une explication.

Le 16F88 à la peau dur, avant de le tuer il faut vraiment faire une fausse manœuvre, c'est un de mes Pic préféré.

==> A+



Bonjour :)
Je viens de flash ton HEX. Seulement 2 fils, 5V/GND => rien sur RA2
Je ne pense pas que ça vienne de mon programme, j'ai l'habitude des pics, mais là, je suis surpris.

PIC16F88 ne démarre pas
venom
Avatar de l’utilisateur
Passioné
Passioné
Messages : 391
Âge : 33
Enregistré en : avril 2016
Localisation : . <------ ici
Contact :

#5 Message par venom » mar. 9 oct. 2018 19:05

Bonsoir lake et bonsoir a tous.
Soit le bienvenu ici.

Tu dit que ton pic ne demarre pas ? Pourtant sur ton screenshots tu arrive a le programmer ? Ou je n'ai pas tout suivi lol






@++
En fait tout est une question de BIT ? :-D

PIC16F88 ne démarre pas
lake
Membre
Membre
Messages : 5
Enregistré en : octobre 2018

#6 Message par lake » mar. 9 oct. 2018 19:08

venom a écrit :Bonsoir lake et bonsoir a tous.
Soit le bienvenu ici.

Tu dit que ton pic ne demarre pas ? Pourtant sur ton screenshots tu arrive a le programmer ? Ou je n'ai pas tout suivi lol






@++


Oui j'arrive à le programmer, tout va bien de ce côté là. Mais il ne réagit pas du tout, comme si il n'était pas cadencé.

Edit: J'ai titillé avec le multimètre une des pattes et la LED s'est allumée o_O
Je sens qu'ils vont connaître le classement vertical ^^

PIC16F88 ne démarre pas
Temps-x
Avatar de l’utilisateur
Confirmé
Confirmé
Messages : 894
Enregistré en : juillet 2016
Localisation : Terre

#7 Message par Temps-x » mar. 9 oct. 2018 19:41

1) voir si ton PicKit3 n'est pas endommagé, essai de programmer un autre Pic, si tu as !!

2) A vérifié si tu n'aurais pas mis un bootloader, ça pourrais expliquer pas mal de chose

Après, si tu as essayé le fichier que je te propose, et suivi le schéma de branchement c'est que ton Pic est hors fonction. :cry:

==> A+
Quand la souris nargue le chat, c'est que son trou n'est pas loin.

PIC16F88 ne démarre pas
lake
Membre
Membre
Messages : 5
Enregistré en : octobre 2018

#8 Message par lake » mar. 9 oct. 2018 19:46

Temps-x a écrit :1) voir si ton PicKit3 n'est pas endommagé, essai de programmer un autre Pic, si tu as !!

2) A vérifié si tu n'aurais pas mis un bootloader, ça pourrais expliquer pas mal de chose

Après, si tu as essayé le fichier que je te propose, et suivi le schéma de branchement c'est que ton Pic est hors fonction. :cry:

==> A+


1) Oui pas de soucis, j'utilise des 18F depuis un moment sans aucun soucis.
2) Ils sont vierges !

RIP :cry:

PIC16F88 ne démarre pas
venom
Avatar de l’utilisateur
Passioné
Passioné
Messages : 391
Âge : 33
Enregistré en : avril 2016
Localisation : . <------ ici
Contact :

#9 Message par venom » mar. 9 oct. 2018 20:53

lake a écrit :Oui j'arrive à le programmer, tout va bien de ce côté là. Mais il ne réagit pas du tout, comme si il n'était pas cadencé.


Ah ok je comprends mieux :wink:







@++
En fait tout est une question de BIT ? :-D

PIC16F88 ne démarre pas
paulfjujo
Avatar de l’utilisateur
Expert
Expert
Messages : 1057
Âge : 68
Enregistré en : juillet 2015
Localisation : 01120
Contact :

#10 Message par paulfjujo » mar. 9 oct. 2018 21:00

bonsoir,


as-tu bien tiré le MCLR au +VCC via une 4,7K ou 10K ?
essaie d'enlever Brown-Out Reset
mettre sur disable


à jeremy
Je suis surpris de voir une interface d'IDE MikroC de mikroelekronika avec l'utilisation d'un PICKIT3 de microchip ?
Tu te sers du .hex de mikroC ?


je me sers exclusivement du pickit2 ou Pickit3 avec mikroC sans problemes.
il suffit de charger le Hex cree par mikroC
de plus des qu'il est modifié
via la fonctionnalité AUTO load du pickit .. il se recharge automatiquement
apres chaque compilation


Retourner vers « Langage C »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité