Bienvenue aux nouveaux arrivants sur FantasPic !

- Pensez à lire les règles durant votre visite, il n'y en a pas beaucoup, mais encore faut-il les respecter .
- N’hésitez pas à faire des remarques et/ou suggestions sur le Forum, dans le but de l'améliorer et de rendre vos prochaines visites plus agréables.
- Vous pouvez regarder votre "panneau de l'utilisateur" afin de configurer vos préférences.
- Un passage par "l'utilisation du forum" est recommandé pour connaître les fonctionnalités du forum.

--- L’équipe FantasPic ---
On parle des Pics, sans rapport avec le langage ou la programmation

Modérateur : Jérémy

problème d'alimentation d'un afficheur 7 segments
ducran lapoigne
Avatar de l’utilisateur
Débutant
Débutant
Messages : 96
Enregistré en : septembre 2015

#11 Message par ducran lapoigne » mer. 1 août 2018 20:34

bonsoir,

pour faire éclairer correctement un segment, tablons sur 10 mA

faut abandonner l' idée que le 4094 pourra tirer ce courant

si tu y tiens absolument essaie ce schéma:

aff pic.JPG


++ sur le forum

Antoine
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.

problème d'alimentation d'un afficheur 7 segments
JJE
Amateur
Amateur
Messages : 159
Âge : 78
Enregistré en : novembre 2017
Localisation : Picardie

#12 Message par JJE » jeu. 2 août 2018 10:53

Bonjour ducran lapoigne, merci de t'intéresser à mon problème.
J'ai réalisé sur platine d'essais les montages suivants :
schéma logique.pdf
un seul programme pour les deux qui envoie 8 0 au HC4094 et met à 0 GP4, sans effet sur le montage 2 puisque non connecté.
Le TDS du montage 2 brille de mille feux, celui du montage 1 est très pâle, autant que je puisse en juger sensiblement du même éclat que dans le montage multiplexé décrit dans un post précédent. Remarque que le changement de résistance (de 660 à 330) semble sans effet.
Curieusement, si au lieu d'allumer tous les segments, je n'en allume que deux, je ne vois pas un gros changement de luminosité alors qu'on est dans les clous du BC557, mais c'est assez subjectif :sifflotte:
J'ai commandé des BC369 qui délivrent 1A, peut-être vont-ils régler ce problème, je tiendrai au courant le forum.
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.
Cordialement

JJE

C'est pas parcequ'on n'a rien à dire qu'il faut fermer sa G....e

problème d'alimentation d'un afficheur 7 segments
cyril13110
Passioné
Passioné
Messages : 478
Âge : 36
Enregistré en : avril 2016
Localisation : 13

#13 Message par cyril13110 » jeu. 2 août 2018 11:09

hello, je viens de penser a un composant qui pourrait te simplifier la vie, un reseau darlington type ULM2803A de memoire.
cest des composants qui sont utilisés comme etage de puissances pour les moteurs et qui delivre jusqua 500mA.....

problème d'alimentation d'un afficheur 7 segments
paulfjujo
Avatar de l’utilisateur
Expert
Expert
Messages : 1133
Âge : 68
Enregistré en : juillet 2015
Localisation : 01800
Contact :

#14 Message par paulfjujo » jeu. 2 août 2018 22:55

bonsoir


ULN2083 ou 2084 sortie NPN
et UDN2981 sortie PNP
Aides toi, le ciel ou Fantastpic t'aideras

problème d'alimentation d'un afficheur 7 segments
cyril13110
Passioné
Passioné
Messages : 478
Âge : 36
Enregistré en : avril 2016
Localisation : 13

#15 Message par cyril13110 » jeu. 2 août 2018 23:02

paulfjujo a écrit :bonsoir


ULN2083 ou 2084 sortie NPN
et UDN2981 sortie PNP


ha mince jai raté le quintè....je vais changer d'écurie je pense.....
dehors!!

problème d'alimentation d'un afficheur 7 segments
elektrax
Débutant
Débutant
Messages : 50
Enregistré en : septembre 2015

#16 Message par elektrax » ven. 3 août 2018 04:40

dans electpratique n243 01/2000, une minuterie 2 digits(1 a 99 minutes) avec 1 12c508+2 4094+ 2 uln2003 aux sorties des 4094 pour les CATHODES des afficheurs anodes communes reliées directement au +5volts, pas de multiplexage
pas de code source, uniquement fichier hex

problème d'alimentation d'un afficheur 7 segments
JJE
Amateur
Amateur
Messages : 159
Âge : 78
Enregistré en : novembre 2017
Localisation : Picardie

#17 Message par JJE » ven. 3 août 2018 07:29

Bonjour à tous, c'est vrai que ces circuits simplifieraient beaucoup le câblage, je vais quand même essayer les BC557 puisqu'ils sont commandés.
à elektrax, c'est pour remplacer un circuit déjà réalisé et opérationnel avec huit 4094 connectés à 8 TDS anode commune directement connectées au +5V par un circuit plus simple utilisant le multiplexage (et pour connaître cette technique) que je me suis lancé là dedans. J'ai attaqué les TDS directement depuis les sorties des 4094 sans problème manifeste ce qui laisse à penser que les uln2003 sont superflus mais peut-être pas pour un vrai electronicien :roll:
Cordialement

JJE

C'est pas parcequ'on n'a rien à dire qu'il faut fermer sa G....e

problème d'alimentation d'un afficheur 7 segments
cyril13110
Passioné
Passioné
Messages : 478
Âge : 36
Enregistré en : avril 2016
Localisation : 13

#18 Message par cyril13110 » ven. 3 août 2018 10:35

JJE a écrit :.......mais peut-être pas pour un vrai electronicien :roll:


bonjour a tous,
il ny a pas de vrai ni de faut électronicien, mais plutôt des electroniciens passionné plus ou moins expérimentés qui font des experiences, crames des composants, trouvent des astuces, et qui grattent depuis plus ou moins longtemps.....

problème d'alimentation d'un afficheur 7 segments
F6FCO
Avatar de l’utilisateur
Confirmé
Confirmé
Messages : 633
Âge : 64
Enregistré en : décembre 2017
Localisation : Furtif je suis.
Contact :

#19 Message par F6FCO » ven. 3 août 2018 13:24

Bonjour JJE et tous le monde,
Je ne lis ce sujet que maintenant, pour revenir à l'idée première si tu dois alimenter tes anodes avec un PNP solide tu as le TIP42 en boitier TO220 qui passe 6A. Son homologue NPN est le TIP41.
Une porte nand prend 2 bits en entrée... cochonne va !!!

problème d'alimentation d'un afficheur 7 segments
ducran lapoigne
Avatar de l’utilisateur
Débutant
Débutant
Messages : 96
Enregistré en : septembre 2015

#20 Message par ducran lapoigne » sam. 4 août 2018 10:54

bonjour jje,
contrairement aux autres je ne pense pas que changer le BC557 par un plus puissant améliorera les choses
avec 10 mA par segment, on est encore bon (iC 557 = 100 mA)
ton problème avec le 1er schéma est que le bc557 n' est pas saturé
essaie un montage darlington pour + de gain
dar557.JPG
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.


Retourner vers « Généralités sur les PICs »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 0 invité