Bienvenue aux nouveaux arrivants sur FantasPic !

- Pensez à lire les règles durant votre visite, il n'y en a pas beaucoup, mais encore faut-il les respecter .
- N’hésitez pas à faire des remarques et/ou suggestions sur le Forum, dans le but de l'améliorer et de rendre vos prochaines visites plus agréables.
- Vous pouvez regarder votre "panneau de l'utilisateur" afin de configurer vos préférences.
- Un passage par "l'utilisation du forum" est recommandé pour connaître les fonctionnalités du forum.

--- L’équipe FantasPic ---
On parle des Pics, sans rapport avec le langage ou la programmation

Modérateur : Jérémy

Simulation d'un PIC16F628 sous Proteus
Burp
Membre
Membre
Messages : 13
Enregistré en : juin 2018

#1 Message par Burp » mer. 20 juin 2018 18:28

Bonjour
Je souhaite réaliser une maquette simulant un carrefour routier. J'ai saisis un schéma avec Proteus. La partie programmation est réalisé avec Flowcode 6. J'ai un message d'erreur : [PIC16] PC=0x0021. Processor has been reset by watchdog timer expiring at time 3.060000. [U1]
Schéma proteus.JPG

Avez vous une idée sur le problème ?
Cordialement
Burp
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.

Simulation d'un PIC16F628 sous Proteus
Jérémy
Administrateur du site
Administrateur du site
Messages : 2112
Âge : 39
Enregistré en : juillet 2015
Localisation : Dans le sud
Contact :

#2 Message par Jérémy » mer. 20 juin 2018 18:36

Bonjour Burp et bienvenue sur FantasPIC,

En théorie sur le forum, on ne parle de flowcode, mais comme il est calme , ça roule ! :wink:

Je pense que ton probléme est plutôt explicite. Le watchdog sur ton PIC est activé, donc il redémarre ton PIC perpétuellement après un certain temps. Il te faut désactiver cette option dans la configuration, ou alors remettre à zéro le watchdog dans ton programme.

Ne connaissant pas flowcode , je ne peux pas trop t'en dire plus !

A+
C'est en faisant des erreurs, que l'on apprend le mieux !!!

Simulation d'un PIC16F628 sous Proteus
Burp
Membre
Membre
Messages : 13
Enregistré en : juin 2018

#3 Message par Burp » mer. 20 juin 2018 18:55

Bonjour Jérémy
Quelle réactivité !
Je ne suis pas familiarisé avec Flowcode. J'ai tout de même trouvé comment le désactiver. Il me reste à programmer le PIC.
Merci pour l'aide
Bonne fin de journée
Burp

Simulation d'un PIC16F628 sous Proteus
venom
Avatar de l’utilisateur
Passioné
Passioné
Messages : 372
Âge : 32
Enregistré en : avril 2016
Localisation : . <------ ici
Contact :

#4 Message par venom » jeu. 21 juin 2018 20:51

Burp a écrit :J'ai tout de même trouvé comment le désactiver.


Bonjour et bienvenue sur le forum Burp. Du coup ta simu fonctionne maintenant ?






@++
En fait tout est une question de BIT ? :-D

Simulation d'un PIC16F628 sous Proteus
Burp
Membre
Membre
Messages : 13
Enregistré en : juin 2018

#5 Message par Burp » ven. 22 juin 2018 08:27

Bonjour Venom
La simulation fonctionne avec un programme consistant à faire clignoter une LED. J'ai programmé le PIC avec le programmateur EB006V9 et comme logiciel Mloader. Là aussi, pas de soucis. Le montage fonctionne sur plaque LAB. Par contre, pour l'ensemble de la maquette du feu tricolore, j'ai un autre problème de simulation. Ça se lance correctement puis ça bloque. Etant au boulot, je n'ai pas la ligne précisant l'erreur. D'après ce que j'ai lu, ça serait un problème de paramétrage d'animation sur Proteus. Ce soir soir, je déposerai le log.
Bonne journée
Burp

Simulation d'un PIC16F628 sous Proteus
Burp
Membre
Membre
Messages : 13
Enregistré en : juin 2018

#6 Message par Burp » ven. 22 juin 2018 09:28

J'ai réussi à récupérer les erreurs.
log.JPG
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.

Simulation d'un PIC16F628 sous Proteus
Burp
Membre
Membre
Messages : 13
Enregistré en : juin 2018

#7 Message par Burp » dim. 24 juin 2018 13:39

Bonjour
Pour donner suite au problème de simulation, j'ai trouvé le problème. La boche 10 (com) de l'ULN2804 devait être reliée au VDD. Il me reste à construire la maquette et vérifier le fonctionnement.
Bonne journée
Burp

Simulation d'un PIC16F628 sous Proteus
Jérémy
Administrateur du site
Administrateur du site
Messages : 2112
Âge : 39
Enregistré en : juillet 2015
Localisation : Dans le sud
Contact :

#8 Message par Jérémy » dim. 24 juin 2018 13:58

Burp a écrit :Source du message Il me reste à construire la maquette et vérifier le fonctionnement.


Et c'est la que vont arriver les véritables problèmes :langue: .......
C'est en faisant des erreurs, que l'on apprend le mieux !!!

Simulation d'un PIC16F628 sous Proteus
paulfjujo
Avatar de l’utilisateur
Expert
Expert
Messages : 1032
Âge : 67
Enregistré en : juillet 2015
Localisation : 01120
Contact :

#9 Message par paulfjujo » dim. 24 juin 2018 16:43

Burp a écrit : j'ai trouvé le problème. La boche 10 (com) de l'ULN2804 devait être reliée au VDD. Il me reste à construire la maquette et vérifier le fonctionnement.


j'en suis pas aussi sur ...
ce serait plutot la broche 9 qui n'est pas au Gnd 0V !
TEST ULN2084

C'est une vraie plaie, ces simulateurs qui escamotent des pins ...

la broche 10 c'est plutot pour
soit faire un "test-lampes" de toutes les sorties, en mettant Pin 10 au 0V
soit pour mettre les diode en anti-retour avec la charge , en mettant la pin 10 au + alim
dans le cas de charge sortie= R+ led .. on peut laisser la pin 10 en l'air.

Simulation d'un PIC16F628 sous Proteus
Burp
Membre
Membre
Messages : 13
Enregistré en : juin 2018

#10 Message par Burp » dim. 24 juin 2018 20:52

Bonsoir Paulfjujo
Je parle du 2804 et non du 2084 comme tu le précises. Je confirme que c'est la broche 10 que j'ai branché sur le 5V. J'ai tenté de la relié au GND pour voir mais les LED s'allument et restent figées.
J'ai trouvé très bien ton lien. J'ai vu qu'il y a des typons. C'est un sujet sur lequel je voudrais parler mais dois je ouvrir un autre topic ?
Bonne soirée
Burp


Retourner vers « Généralités sur les PICs »

Qui est en ligne

Utilisateurs parcourant ce forum : Google [Bot] et 7 invités