Bienvenue aux nouveaux arrivants sur FantasPic !

- Pensez à lire les règles durant votre visite, il n'y en a pas beaucoup, mais encore faut-il les respecter .
- N’hésitez pas à faire des remarques et/ou suggestions sur le Forum, dans le but de l'améliorer et de rendre vos prochaines visites plus agréables.
- Vous pouvez regarder votre "panneau de l'utilisateur" afin de configurer vos préférences.
- Un passage par "l'utilisation du forum" est recommandé pour connaître les fonctionnalités du forum.

--- L’équipe FantasPic ---
Forum général sur le langage C !

Modérateur : Jérémy

[résolu] Scan I²C retourne deux adresses.
venom
Avatar de l’utilisateur
Passioné
Passioné
Messages : 391
Âge : 33
Enregistré en : avril 2016
Localisation : . <------ ici
Contact :

#1 Message par venom » jeu. 31 mai 2018 22:00

Bonsoir a tous,

Voilà en ce moment je bosse sur un ds3231 pour essayé de récupérer le résultat en UART. J'ai donc lancer un scan I²C via le code de paulfjujo ici

Le souci c'est que le résultat me renvoi 2 adresses alors qu'il n'y a qu'un module sur le SDA SCL. Comment cela se fait t'il ?
Et dans ce cas la, quel adresse choisir :?

voici le resultat du scan :
Pin RA3 à 1 => mode Bavard ACTIF 

j'ai réduit le resultat du scan car très long ...

 I2C Device at @ 92 not found
 I2C Device at @ 94 not found
 I2C Device at @ 96 not found
 I2C Device at @ 98 not found
 I2C Device at @ 9A not found
 I2C Device at @ 9C not found
 I2C Device at @ 9E not found
 I2C Device at @ A0 not found
 I2C Device at @ A2 not found
 I2C Device at @ A4 not found
 I2C Device at @ A6 not found
 I2C Device at @ A8 not found
 I2C Device at @ AA not found
 I2C Device at @ AC not found
 I2C Device at @ AE ... soit 174  Found OK  

 I2C Device at @ B0 not found
 I2C Device at @ B2 not found
 I2C Device at @ B4 not found
 I2C Device at @ B6 not found
 I2C Device at @ B8 not found
 I2C Device at @ BA not found
 I2C Device at @ BC not found
 I2C Device at @ BE not found
 I2C Device at @ C0 not found
 I2C Device at @ C2 not found
 I2C Device at @ C4 not found
 I2C Device at @ C6 not found
 I2C Device at @ C8 not found
 I2C Device at @ CA not found
 I2C Device at @ CC not found
 I2C Device at @ CE not found
 I2C Device at @ D0 ... soit 208  Found OK  

 I2C Device at @ D2 not found
 I2C Device at @ D4 not found
 I2C Device at @ D6 not found
 I2C Device at @ D8 not found
 I2C Device at @ DA not found
 I2C Device at @ DC not found
 I2C Device at @ DE not found
 I2C Device at @ E0 not found
 I2C Device at @ E2 not found
 I2C Device at @ E4 not found
 I2C Device at @ E6 not found
 I2C Device at @ E8 not found
 I2C Device at @ EC not found
 I2C Device at @ EE not found
 I2C Device at @ F0 not found
 I2C Device at @ F4 not found
 I2C Device at @ F6 not found
 I2C Device at @ F8 not found
 I2C Device at @ FC not found

 Fin de recherche device


Merci de votre aide.






@++
Modifié en dernier par venom le ven. 1 juin 2018 12:18, modifié 1 fois.
En fait tout est une question de BIT ? :-D

Scan I²C retourne deux adresses.
paulfjujo
Avatar de l’utilisateur
Expert
Expert
Messages : 1059
Âge : 68
Enregistré en : juillet 2015
Localisation : 01120
Contact :

#2 Message par paulfjujo » ven. 1 juin 2018 08:36

bonjour ,

normal,il y a 2 devices sur ton module :
RTC + Eeprom


RTC en 0xD0 comme la DS1307

Scan I²C retourne deux adresses.
venom
Avatar de l’utilisateur
Passioné
Passioné
Messages : 391
Âge : 33
Enregistré en : avril 2016
Localisation : . <------ ici
Contact :

#3 Message par venom » ven. 1 juin 2018 12:18

:oops: oops. Autant pour moi.






@++
En fait tout est une question de BIT ? :-D


Retourner vers « Langage C »

Qui est en ligne

Utilisateurs parcourant ce forum : Bing [Bot] et 1 invité