Bienvenue aux nouveaux arrivants sur FantasPic !

- Pensez à lire les règles durant votre visite, il n'y en a pas beaucoup, mais encore faut-il les respecter .
- N’hésitez pas à faire des remarques et/ou suggestions sur le Forum, dans le but de l'améliorer et de rendre vos prochaines visites plus agréables.
- Vous pouvez regarder votre "panneau de l'utilisateur" afin de configurer vos préférences.
- Un passage par "l'utilisation du forum" est recommandé pour connaître les fonctionnalités du forum.

--- L’équipe FantasPic ---
On parle des Pics, sans rapport avec le langage ou la programmation

Modérateur : Jérémy

soucis avec PicKit 3
JJE
Amateur
Amateur
Messages : 143
Âge : 78
Enregistré en : novembre 2017
Localisation : Picardie

#11 Message par JJE » mer. 31 janv. 2018 17:39 lien vers la Data-Sheet : Cliquez ici

merci satinas, le téléchargement et l'installation de la version8.92 de MPLAB se sont bien déroulés, j'ai bien le firmwar 0.1.28.90de pickit 3 mais toujours le message
    Target Device ID (00003fe0) does not match expected DeviceID (00000fc0).
seul le Device ID a changé
et, bien sûr il refuse de programmer mon pic
Cordialement

JJE

C'est pas parcequ'on n'a rien à dire qu'il faut fermer sa G....e

soucis avec PicKit 3
satinas
Passioné
Passioné
Messages : 314
Enregistré en : novembre 2015

#12 Message par satinas » mer. 31 janv. 2018 17:59 lien vers la Data-Sheet : Cliquez ici

bizarre, 0xfc0 c'est le device id code du 12F675, celui du 16F88 c'est bien le 0x760

soucis avec PicKit 3
JJE
Amateur
Amateur
Messages : 143
Âge : 78
Enregistré en : novembre 2017
Localisation : Picardie

#13 Message par JJE » mer. 31 janv. 2018 18:22 lien vers la Data-Sheet : Cliquez ici

J'ai fini par mettre en doute le bon fonctionnement de mon Pic et cablé pickit 3 sur un 12F675 que j'avais sous la main.
Même comportement avec une petite nuance dans le message, les Devices ID ont changé.

Code : Tout sélectionner


Target Device ID 
(00000000) does not match expected Device ID (00000fc0).
Cordialement

JJE

C'est pas parcequ'on n'a rien à dire qu'il faut fermer sa G....e

soucis avec PicKit 3
satinas
Passioné
Passioné
Messages : 314
Enregistré en : novembre 2015

#14 Message par satinas » mer. 31 janv. 2018 18:44 lien vers la Data-Sheet : Cliquez ici

Possibilité d'incompatibilité entre ta version de Windows et Mplab.
Au pif, je dirais que la probabilité d'un pickit3 low-cost défectueux est de 1 sur 10.
As-tu fait le test proposé par JMarc, alimenter le 12F675 avec le pickit3 en 5V (voir menu de config du pickit3).
Ne pas inverser PGC et PGD, une résistance entre Vpp et Vdd, etc ...
Essaye avec le pickit3 sélectionné en programmer, puis debugger

soucis avec PicKit 3
F6FCO
Avatar de l’utilisateur
Confirmé
Confirmé
Messages : 599
Âge : 64
Enregistré en : décembre 2017
Localisation : Furtif je suis.
Contact :

#15 Message par F6FCO » sam. 3 févr. 2018 11:51 lien vers la Data-Sheet : Cliquez ici

Bonjour tous,
J'ai fais la même manip que JJE hier soir, à savoir faire tourner un programme qui fonctionne et se compile très bien sur un 16F84 sur un 16F88, bien sur en n'oubliant pas de changer la cible dans configure/Select Device et les déclarations en haut de programme.
Rechangé de nouveau avec avec un 16F84A et çà fonctionne très bien, donc ce n'est pas le pickit. JJE je te suggère d'essayer ton pickit sur un 16F84 pour le valider.
J'ai les mêmes messages d'erreur que lui avec le rouge et tout et tout. Je voulais en parler mais il m'a devancé :wink:
Les 16F88 viennent d'Aliexpress.

(En ce qui concerne la solution de Temps_X, le pickit en question ne fonctionne qu'avec le soft standalone, mais pas sous MPlab.)
Une porte nand prend 2 bits en entrée... cochonne va !!!

soucis avec PicKit 3
satinas
Passioné
Passioné
Messages : 314
Enregistré en : novembre 2015

#16 Message par satinas » sam. 3 févr. 2018 12:31 lien vers la Data-Sheet : Cliquez ici

Bonjour à tous,
Je viens de faire un essai avec un 12F675 de chez Microchip sur un Pickit3 low-cost. Alimenté en 5V par le Pickit, aucun problème pour le détecter avec Mplab, en mode programmer et en mode debugger.

soucis avec PicKit 3
JJE
Amateur
Amateur
Messages : 143
Âge : 78
Enregistré en : novembre 2017
Localisation : Picardie

#17 Message par JJE » sam. 3 févr. 2018 12:44 lien vers la Data-Sheet : Cliquez ici

erci, je l'avais démonté, je vais réessayer cet AM
Cordialement

JJE

C'est pas parcequ'on n'a rien à dire qu'il faut fermer sa G....e

soucis avec PicKit 3
JJE
Amateur
Amateur
Messages : 143
Âge : 78
Enregistré en : novembre 2017
Localisation : Picardie

#18 Message par JJE » sam. 3 févr. 2018 12:44 lien vers la Data-Sheet : Cliquez ici

erci, je l'avais démonté, je vais réessayer cet AM
Cordialement

JJE

C'est pas parcequ'on n'a rien à dire qu'il faut fermer sa G....e

soucis avec PicKit 3
Temps-x
Avatar de l’utilisateur
Confirmé
Confirmé
Messages : 962
Enregistré en : juillet 2016
Localisation : Terre

#19 Message par Temps-x » sam. 3 févr. 2018 13:25 lien vers la Data-Sheet : Cliquez ici

Bonjour tout le forum,

Il serait bien de précisé le système d'exploitation que vous avez utilisé. :wink:

==> A+
Quand la souris nargue le chat, c'est que son trou n'est pas loin.

soucis avec PicKit 3
JJE
Amateur
Amateur
Messages : 143
Âge : 78
Enregistré en : novembre 2017
Localisation : Picardie

#20 Message par JJE » sam. 3 févr. 2018 14:49 lien vers la Data-Sheet : Cliquez ici

WXP
MPLAB 8.92.00.00
PicKit3 Firmware Suite Version...... 01.28.90
Cordialement

JJE

C'est pas parcequ'on n'a rien à dire qu'il faut fermer sa G....e


Retourner vers « Généralités sur les PICs »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité