Bienvenue aux nouveaux arrivants sur FantasPic !

- Pensez à lire les règles durant votre visite, il n'y en a pas beaucoup, mais encore faut-il les respecter .
- N’hésitez pas à faire des remarques et/ou suggestions sur le Forum, dans le but de l'améliorer et de rendre vos prochaines visites plus agréables.
- Vous pouvez regarder votre "panneau de l'utilisateur" afin de configurer vos préférences.
- Un passage par "l'utilisation du forum" est recommandé pour connaître les fonctionnalités du forum.

--- L’équipe FantasPic ---
On parle des Pics, sans rapport avec le langage ou la programmation

Modérateur : Jérémy

Impossible de visualiser mes variables dans MPLA8.92 [Résolu]
F6FCO
Avatar de l’utilisateur
Passioné
Passioné
Messages : 443
Âge : 64
Enregistré en : décembre 2017
Localisation : Furtif je suis.
Contact :

#1 Message par F6FCO » sam. 23 déc. 2017 18:54

Bonsoir tous,
Je me décide à créer un sujet sur mon pbm après beaucoup de recherches, d'essais infructueux et même plusieurs désinstallations/réinstallation de MPLab.
Dans la fenêtre Watch je n'arrive pas à visualiser mes variables, le bouton "Add Symbol" reste désespérément grisé et inopérant. Je peux bien visualiser les registres mais les variables créées. Elles n'apparaissent pas non plus dans la fenêtre File Registers. J'en suis pour l'instant à la partie Intrruptions du cours de Bigonoff et je suis bloqué car pas moyen de visualiser l'évolution de w-temp et status-temp. Je pourrai bien sur passer outre mais le problème se reposera pour la suite du cours.
Modifié en dernier par F6FCO le lun. 25 déc. 2017 19:21, modifié 1 fois.
Une porte nand prend 2 bits en entrée... cochonne va !!!

Impossible de visualiser mes variables dans MPLA8.92
Temps-x
Avatar de l’utilisateur
Confirmé
Confirmé
Messages : 813
Enregistré en : juillet 2016
Localisation : Terre

#2 Message par Temps-x » sam. 23 déc. 2017 22:12

Bonsoir F6FCO,

As tu essayés sur un autre PC ?
Quelle est ton système d'exploitation ?

A+
Quand la souris nargue le chat, c'est que son trou n'est pas loin.

Impossible de visualiser mes variables dans MPLA8.92
F6FCO
Avatar de l’utilisateur
Passioné
Passioné
Messages : 443
Âge : 64
Enregistré en : décembre 2017
Localisation : Furtif je suis.
Contact :

#3 Message par F6FCO » sam. 23 déc. 2017 22:18

W7 64bits sur mes 2 PC.
Sur mon gros PC de bureau çà fonctionne, sur le portable non. C'est sur le portable que c'est important car je passe la moitié des semaines loin de la maison et j'emmène le portable.
Une porte nand prend 2 bits en entrée... cochonne va !!!

Impossible de visualiser mes variables dans MPLA8.92
Temps-x
Avatar de l’utilisateur
Confirmé
Confirmé
Messages : 813
Enregistré en : juillet 2016
Localisation : Terre

#4 Message par Temps-x » sam. 23 déc. 2017 22:31

Marque de ton PC, et année.
Quand la souris nargue le chat, c'est que son trou n'est pas loin.

Impossible de visualiser mes variables dans MPLA8.92
JMarc
Passioné
Passioné
Messages : 486
Enregistré en : août 2016
Localisation : Dans le Sud...

#5 Message par JMarc » sam. 23 déc. 2017 23:07

F6FCO a écrit :Bonsoir tous,

Dans la fenêtre Watch je n'arrive pas à visualiser mes variables, le bouton "Add Symbol" reste désespérément grisé et inopérant. Je peux bien visualiser les registres mais les variables créées. Elles n'apparaissent pas non plus dans la fenêtre File Registers.


Dans file register,il n'y a pas le nom de la variable, d'accord mais a l'adresse de la variable il doit y avoir sa valeur

Impossible de visualiser mes variables dans MPLA8.92
F6FCO
Avatar de l’utilisateur
Passioné
Passioné
Messages : 443
Âge : 64
Enregistré en : décembre 2017
Localisation : Furtif je suis.
Contact :

#6 Message par F6FCO » sam. 23 déc. 2017 23:13

@Jmarc, tu peux avoir le nom et la valeur si tu cliques sur le bouton "symbolic" en bas de la fenêtre. Mais moi je n'ai rien là non plus, ni nom, ni valeur.


@Temps-X:
Portable Toshiba Satellite 64bits
Proc: Intel Celeron B820 1,70Ghz
4Go Ram
Windows 7 Edition Familiale Premium Service Pack1
L'année je ne sais pas, je l'ai acheté chez Rue du Commerce pas cher (400€) il y a déjà 3 ou 4 ans et il faisait partie du bas de gamme.

Je précise que le PC est capable d'afficher ces variable car j'avais déjà parlé du problème quand j'en étais au programme "Clig" début de cours et j'ai eu ce soucis, je l'avais résolu en cliquant sur Debugger/Stopwatch. Malheureusement çà ne fonctionne pas pour ce nouveau projet.
Une porte nand prend 2 bits en entrée... cochonne va !!!

Impossible de visualiser mes variables dans MPLA8.92
Temps-x
Avatar de l’utilisateur
Confirmé
Confirmé
Messages : 813
Enregistré en : juillet 2016
Localisation : Terre

#7 Message par Temps-x » dim. 24 déc. 2017 01:42

Re

Si tu as un antivirus désactive le,

je l'ai acheté chez Rue du Commerce


Je connais cette rue, pas mal de vendeur asiatique qui se débarrasse de leur matériel défectueux, à prix défiant toute concurrence.
J'ai eu pas mal de soucis avec eu, je pourrais te raconter, mais ça changerais rien à ton problème. :furieux:

Je pense que c'est ton PC qui doit avoir des problèmes, et ça parait logique, comme j'ai 3 portable, je fais l'essai demain sur les 3.

Comme Windows 7 est un bon système d'exploitation, je ne peux pas le soupçonné.

Les Celerons en général, utilise une parti de la ram pour le graphique, tu pourrais en premier temps contrôler ta ram en suivant ceci

Page 1 : https://www.pcastuces.com/pratique/wind ... /page1.htm
page 2 : https://www.pcastuces.com/pratique/wind ... /page2.htm
page 3 : https://www.pcastuces.com/pratique/wind ... /page3.htm
Page 4 : https://www.pcastuces.com/pratique/wind ... /page4.htm

Pour l'instant j'ai pas de réponse à ton problème, je te tiens au courant vers fin de soirée sur les tests


Bonne soirée :wink:

A+
Modifié en dernier par Temps-x le dim. 24 déc. 2017 17:29, modifié 1 fois.
Quand la souris nargue le chat, c'est que son trou n'est pas loin.

Impossible de visualiser mes variables dans MPLA8.92
F6FCO
Avatar de l’utilisateur
Passioné
Passioné
Messages : 443
Âge : 64
Enregistré en : décembre 2017
Localisation : Furtif je suis.
Contact :

#8 Message par F6FCO » dim. 24 déc. 2017 10:22

Temps-x a écrit : qui se débarrasse de leur matériel affectueux,

Moi aussi je l'aime bien ce petit PC :-D

De plus c'est un W7 embarqué que je ne peux pas réinstaller sinon j'aurai fais un formatage et réinstallation.
Je vais faire les tests.
Une porte nand prend 2 bits en entrée... cochonne va !!!

Impossible de visualiser mes variables dans MPLA8.92
Temps-x
Avatar de l’utilisateur
Confirmé
Confirmé
Messages : 813
Enregistré en : juillet 2016
Localisation : Terre

#9 Message par Temps-x » dim. 24 déc. 2017 17:12

Bonsoir F6FCO, et tout le forum,

Et ben voila les essais,

1) Petit PC portable Asus EeePC, intel(R) Atom(TM) CPU N2600, 1,60Ghz, 1Go Ram, édition Windows starter 32 bits, année 2009
ça fonction bien, j'ai aucun problème

2) PC portable Toshiba, Genuine intel(R) CPU T2050, 1,60Ghz, 1Go Ram, Windows XP Media Center 32 bits(Pack 2) année 2002
ça fonction bien, j'ai aucun problème

3) Essayé avec mon PC AMD Athlon(tm) ll x 2 240 Processeur 2,81Ghz, 2Go Ram, Windows XP 32 bits(pack3), année 2002
ça fonction bien, j'ai aucun problème

Tous mon système est en 32 bits, mais ça change rien au problème, car tu as un bon résultat sur ton Pc fixe.

Ton PC est bien la source de ton problème, si ça vient du matériel tu pourras rien y faire.

Joyeux Noël


A+
Quand la souris nargue le chat, c'est que son trou n'est pas loin.

Impossible de visualiser mes variables dans MPLA8.92
F6FCO
Avatar de l’utilisateur
Passioné
Passioné
Messages : 443
Âge : 64
Enregistré en : décembre 2017
Localisation : Furtif je suis.
Contact :

#10 Message par F6FCO » dim. 24 déc. 2017 18:30

J'ai fais les essais de tes liens aussi et tout est bon.
Je ne suis pas sur que le portable soit en cause puisque j'ai déjà pu les visualiser dessus (programme Clig). Je continue à chercher.

Joyeux Noel
JC
Une porte nand prend 2 bits en entrée... cochonne va !!!


Retourner vers « Généralités sur les PICs »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 3 invités