Bienvenue aux nouveaux arrivants sur FantasPic !

- Pensez à lire les règles durant votre visite, il n'y en a pas beaucoup, mais encore faut-il les respecter .
- N’hésitez pas à faire des remarques et/ou suggestions sur le Forum, dans le but de l'améliorer et de rendre vos prochaines visites plus agréables.
- Vous pouvez regarder votre "panneau de l'utilisateur" afin de configurer vos préférences.
- Un passage par "l'utilisation du forum" est recommandé pour connaître les fonctionnalités du forum.

--- L’équipe FantasPic ---
On parle des Pics, sans rapport avec le langage ou la programmation

Modérateur : Jérémy

MPLAB, visu des variables dans la fenetre Watch
F6FCO
Avatar de l’utilisateur
Amateur
Amateur
Messages : 145
Âge : 63
Enregistré en : décembre 2017
Localisation : Furtif je suis.
Contact :

#21 Message par F6FCO » sam. 16 déc. 2017 10:04

Hello et bonjour tous,
Bon, toujours pas accès aux variables, fenêtre validée ou pas. J'ai installé MPLAB sur mon PC de bureau, tout fonctionne parfaitement et je peux les voir, c'est seulement sur mon petit PC portable que çà ne veut pas.
Comme je me déplace dans la semaine et que je veux pouvoir travailler l'assembleur le soir c'est sur le portable que j'ai besoin d'avoir MPLAB donc j'ai désinstallé et réinstallé.
Et le problème persiste, Add Symbol reste déséspérement grisé :sad:

Mais un phénomène me laisse un peu perplexe: je désinstalle MPLAB (avec CCleaner) et le réinstalle. Au premier démarrage je devrai me retrouver avec une IDE vierge, mais non il a chargé le projet Clig de TempsX et gardé les modifs de couleurs de la zone texte. Je me dis que la désinstallation n'a pas été aussi complète que je l'aurai voulu. J'y retourne.
Modifié en dernier par F6FCO le sam. 16 déc. 2017 10:10, modifié 1 fois.

MPLAB, visu des variables dans la fenetre Watch
Jérémy
Administrateur du site
Administrateur du site
Messages : 1882
Âge : 38
Enregistré en : juillet 2015
Localisation : Dans le sud
Contact :

#22 Message par Jérémy » sam. 16 déc. 2017 10:07

Bonjour ,

Peut être un problème de driver ou de firmware ! car si ca focntionne sur l'un ce devrait avec l'autre . Même OS ?
C'est en faisant des erreurs, que l'on apprend le mieux !!!

MPLAB, visu des variables dans la fenetre Watch
F6FCO
Avatar de l’utilisateur
Amateur
Amateur
Messages : 145
Âge : 63
Enregistré en : décembre 2017
Localisation : Furtif je suis.
Contact :

#23 Message par F6FCO » sam. 16 déc. 2017 10:12

Oui, W7 64bits sur les deux et même fichier d'installation MPlab, juste que celui de bureau est un PC qui tient la route alors que le portable est une brouette équipée d'un Celeron rameur. Je refais un essai en allant cette fois nettoyer tous les fichiers qui pourraient rester sur le dd.

MPLAB, visu des variables dans la fenetre Watch
F6FCO
Avatar de l’utilisateur
Amateur
Amateur
Messages : 145
Âge : 63
Enregistré en : décembre 2017
Localisation : Furtif je suis.
Contact :

#24 Message par F6FCO » sam. 16 déc. 2017 10:42

Je viens de tout réinstaller de nouveau proprement et même topo, je ne sais plus quoi faire :sad:

MPLAB, visu des variables dans la fenetre Watch
Jérémy
Administrateur du site
Administrateur du site
Messages : 1882
Âge : 38
Enregistré en : juillet 2015
Localisation : Dans le sud
Contact :

#25 Message par Jérémy » sam. 16 déc. 2017 11:06

Même empalcement et repertoire d'instal ???

Je ne crois pas trop à un problème de RAM . Je ne sais pas trop quoi te dire !
C'est en faisant des erreurs, que l'on apprend le mieux !!!

MPLAB, visu des variables dans la fenetre Watch
F6FCO
Avatar de l’utilisateur
Amateur
Amateur
Messages : 145
Âge : 63
Enregistré en : décembre 2017
Localisation : Furtif je suis.
Contact :

#26 Message par F6FCO » sam. 16 déc. 2017 11:29

Oui même emplacement. Je vais devoir continuer sans visualiser les variables, pas bien pratique pour suivre l'évolution d'un programme mais je n'ai pas le choix. Je ne comprends pas que çà fonctionne sur un PC et pas sur l'autre, j'ai parcouru les menus des deux MPlab pour essayer de trouver une différence de config mais rien.

MPLAB, visu des variables dans la fenetre Watch
satinas
Amateur
Amateur
Messages : 185
Enregistré en : novembre 2015

#27 Message par satinas » sam. 16 déc. 2017 11:46

Bonjour à tous,

Dans le menu "Project/Build_Options/Project/MPASM suite" si l'option "Generate relocatable code" est cochée, décoche la et coche "Generate absolute code"
Puis il faut un nouveau build
http://www.microchip.com/forums/m477941.aspx

MPLAB, visu des variables dans la fenetre Watch
F6FCO
Avatar de l’utilisateur
Amateur
Amateur
Messages : 145
Âge : 63
Enregistré en : décembre 2017
Localisation : Furtif je suis.
Contact :

#28 Message par F6FCO » sam. 16 déc. 2017 12:18

Hélas, rien n'y fait. J'ai tenté de cocher chaque case tout à tour, Add Symbol reste grisé. J'ai également recréé un nouveau projet avec Générate absolute code cochée et c'est pareil.
Je pourrai toujours aller visualiser mes variables directement dans la mémoire à partir de 0C mais dés qu'il y aura beaucoup de variables ce sera impossible à gérer.

MPLAB, visu des variables dans la fenetre Watch
F6FCO
Avatar de l’utilisateur
Amateur
Amateur
Messages : 145
Âge : 63
Enregistré en : décembre 2017
Localisation : Furtif je suis.
Contact :

#29 Message par F6FCO » sam. 16 déc. 2017 12:36

YEEEESSSSSSS !!!!
Il fallait cliquer sur Debugger/StopWatch et Add Symbol est redevenu valide. Ca pourra peut-être servir à d'autres débutants. Je vous remercie tous pour votre aide :-D

Coté positif de la chose: à force d'aller fouiller partout j'ai bien progressé dans MPLAB :wink:

Allez je suis tellement content faut fêter çà, petit hors-sujet pour Temps X: Pas besoin de servo-moteur pour qu'elle attrape les souris, c'est la même marque que le tien et elle aime les radiateurs seulement à partir du moment ou on ne peut plus poser la main dessus.

P1020116.JPG
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.

MPLAB, visu des variables dans la fenetre Watch
JMarc
Passioné
Passioné
Messages : 468
Enregistré en : août 2016
Localisation : Dans le Sud...

#30 Message par JMarc » sam. 16 déc. 2017 18:19

bonjour tout le monde

Désolé pour mon post sur les globales, apres test cela ne fonctionne pas avec 16f84 :cry:
avec le 16f88, 16f877 et le 18f4525 c'est nickel

Je suis ce post avec grand intérêt car je n'ai jamais réussi a faire fonctionner ce fameux watch. je n'ai pas les mêmes fenêtres que vous MPLABx 4.01

je vais dans files registers et je regarde l'adresse de mes variables pour connaître leurs valeurs et si je passe par la déclaration des globales (sauf 16f84) le label s'inscrit a coté de l'adresse


Retourner vers « Généralités sur les PICs »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités