Bienvenue aux nouveaux arrivants sur FantasPic !

- Pensez à lire les règles durant votre visite, il n'y en a pas beaucoup, mais encore faut-il les respecter .
- N’hésitez pas à faire des remarques et/ou suggestions sur le Forum, dans le but de l'améliorer et de rendre vos prochaines visites plus agréables.
- Vous pouvez regarder votre "panneau de l'utilisateur" afin de configurer vos préférences.
- Un passage par "l'utilisation du forum" est recommandé pour connaître les fonctionnalités du forum.

--- L’équipe FantasPic ---
On parle des Pics, sans rapport avec le langage ou la programmation

Modérateur : Jérémy

Pickit3 et MPlab
F6FCO
Avatar de l’utilisateur
Confirmé
Confirmé
Messages : 516
Âge : 64
Enregistré en : décembre 2017
Localisation : Furtif je suis.
Contact :

#1 Message par F6FCO » mer. 13 déc. 2017 19:58

Bonjour à tout le monde,
Je suis nouveau sur le forum, je n'ai pas trouvé de sous-forum de présentation donc je vais le faire succinctement ici :wink: .
Ancien Radio-electronicien je m'intéresse à tout ce qui est technique, bois, métal, électronique, robotique, j'ai un petit site ou je parle un peu de mes réalisation: http://f6fco.pagesperso-orange.fr/ .
Je viens de me mettre à l'apprentissage de la prog en assembleur des pics.
J'ai déjà programmé en assembleur mais il y a très longtemps, sur le Z80, 6502, 68000 et un peu sur les intels 386, programmé aussi l'arduino, me suis frotté à AtmelStudio que j'ai laissé tomber après avoir passé plus de temps à essayer de connecter mon Dragon qu'à vraiment programmer. Pour démarrer en PIC je suis le cours de Bigonoff et la prog du 16F84A.

Mon premier post pour parler d'un problème de config sous MPlab 8.92, j'en suis arrivé au premier montage du 16F84A qui fait clignoter une led.
Deux soucis distincts que je n'arrive pas à résoudre:
- je peux bien sélectionner mon pickit3 en programmer mais pas en debugger, le pickit3 reste en grisé.
- si je charge le fichier hex dans le pic à partir du logiciel du pickit (sans démarrer MPlab) je fais bien clignoter la led, ce qui valide mon montage, par contre si je programme le 16F84 avec le pickit via MPLAB la led ne clignote plus mais reste allumée en permanence.

Ce n'est peut être pas grand chose mais assez pour me bloquer dans l'état de mes connaissances actuelles :roll:
Une porte nand prend 2 bits en entrée... cochonne va !!!

Pickit3 et MPlab
Gérard
Avatar de l’utilisateur
Confirmé
Confirmé
Messages : 828
Âge : 60
Enregistré en : septembre 2015
Localisation : Alsace

#2 Message par Gérard » mer. 13 déc. 2017 21:09

Hello,
Bienvenu à toi.
Concernant la programmation, Bigonoff est vraiment une bonne initiation, histoire de bien comprendre ce qui se passe dans ces petites bêtes.
Après, l'assembleur est un choix (pas le mien).
Tu trouveras ici des amateurs d'asm mais aussi du C (le plus pratiqué) et le Basic (celui que je préfère).
Chez Mikroelektronika, tu trouveras des compilateurs C, Pascal et Basic, la version démo permet de se faire la main.

Je viens de jeter un oeil à ton site et je tombe sur la rubrique CNC. Je pense que j'aurai des questions.

Bon surf sur Fantas-PIC.
Le 11 / 07 / 2017, j'ai commandé une Ford Mustang.
Le 31 / 08 / 2017, j'ai eu la Mustang, un régal.

Pickit3 et MPlab
Temps-x
Avatar de l’utilisateur
Confirmé
Confirmé
Messages : 905
Enregistré en : juillet 2016
Localisation : Terre

#3 Message par Temps-x » jeu. 14 déc. 2017 02:14

Bonjour F6FCO, Gérard, et tous le forum,

Soit le bienvenue sur Fantas-Pic.

écrit par F6FCO

je n'ai pas trouvé de sous-forum de présentation donc je vais le faire succinctement ici :wink:


Effectivement, Jérémy devrait avoir une page pour que les nouveaux inscrit puisse se présenter.

:eek: Super ton site, vraiment génial, j'ai regardé une partie de tes réalisations, chapeau bas ... :bravo:
mais j'ai pas fini, je reviendrais dessus, car il y a beaucoup de choses à voir.

Merci ! pour le partage.

Si tu arrives à faire tous ça, le monde des microcontrôleurs Pic devrait te posé aucun problème, pour ma par je suis dans la section ASM
j'ai commencer un tutoriel Ici pour le clignotement d'une LED.

J'ai ouvert pour tous ceux qui veulent apprendre un post Ici en version ASM

J'ai vu que tu as programmé des atmega, et bien les microcontrôleur Pic son à quelque chose près identique.

Pour démarrer en PIC je suis le cours de Bigonoff et la prog du 16F84A.


Bigonoff, notre maître à tous, si j'avais pas connu son site, jamais j'aurais programmé un PIC.

par contre si je programme le 16F84A avec le pickit3 via MPLAB la led ne clignote plus mais reste allumée en permanence.


J'ai jamais utilisé un ddebugger, sauf celui de l'éditeur de MPlab 8.92, qui me suffit.

Pour ton problème je suppose qu'il rentre en mode debuggage, est la LED reste allumée.

Appui sur F9, et regarde ce qui se passe, si ça reste pareille c'est un problème de configuration dans l'éditeur de
MPlab 8.92

Peux tu faire une capture d'écran ?

A+
Quand la souris nargue le chat, c'est que son trou n'est pas loin.

Pickit3 et MPlab
F6FCO
Avatar de l’utilisateur
Confirmé
Confirmé
Messages : 516
Âge : 64
Enregistré en : décembre 2017
Localisation : Furtif je suis.
Contact :

#4 Message par F6FCO » jeu. 14 déc. 2017 10:24

Merci à tous les deux pour votre réponse et aussi pour les commentaires sur le site, je l'ai justement fait pour en parler :-D, rien de plus triste que de faire des trucs tout seul dans son coin.
J'ai vu ton tuto sur le clignotement de la led et je le suivrai dés que j'aurai résolu mes deux petits pbm actuels.

Si çà ne vous dérange pas pour qu'on ne mélange pas les questions/réponses je vais d'abord parler de la chose qui me tient le plus à cœur pour l'instant: c'est de pouvoir utiliser mon pickit3 sous le mode débugger de MPlab, il reste désespérément grisé. Frustrant de posséder un programmateur capable de faire du débuggage in situ et de ne pas arriver à s'en servir en tant que tel. Ou alors c'est que je n'ai pas compris et qu'on se sert du pickit3 en débuggage d'une autre façon ?
MPLAB ne semble accepter que le simulateur interne et l'ICE2000 que je ne possède pas.


Pour les questions j'en aurai beaucoup d'autres ensuite :roll: .
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.
Une porte nand prend 2 bits en entrée... cochonne va !!!

Pickit3 et MPlab
satinas
Passioné
Passioné
Messages : 302
Enregistré en : novembre 2015

#5 Message par satinas » jeu. 14 déc. 2017 11:14

Bonjour,

Dans Mplab lorsque tu sélectionnes le 16F84 par Configure/select Device, la fenêtre qui s'affiche indique quels sont les programmateurs et debuggers utilisables avec ce chip, et tu peux constater que le pickit3 n'est pas compatible en mode debug.
Il existe des pics plus récents ayant les mêmes broches que le 16F84, 16F1827 par exemple. Avec ces pics tu pourras débugger avec le pickit3.

Pickit3 et MPlab
F6FCO
Avatar de l’utilisateur
Confirmé
Confirmé
Messages : 516
Âge : 64
Enregistré en : décembre 2017
Localisation : Furtif je suis.
Contact :

#6 Message par F6FCO » jeu. 14 déc. 2017 13:05

Tu me rassures là, je croyais à un bug de MPlab. Est-ce que je peux remplacer le 16F84A avec le 16F1827 pour continuer le cours de Bigonoff ? histoire de fonctionnement interne, fusibles, etc.
Une porte nand prend 2 bits en entrée... cochonne va !!!

Pickit3 et MPlab
satinas
Passioné
Passioné
Messages : 302
Enregistré en : novembre 2015

#7 Message par satinas » jeu. 14 déc. 2017 13:20

Pas la peine d'aller chercher le 16F1827, j'avais oublié le 16F88. Regarde les liens plus haut sur les tutoriels de Temp-x. Tous ces pics sont très proches, le 16F88 est plus complexe, et en fais plus que le 16F84, notamment il a un oscillateur interne. Suis le cours et les tutoriels, et si tu bloques on t'aidera.

Pickit3 et MPlab
F6FCO
Avatar de l’utilisateur
Confirmé
Confirmé
Messages : 516
Âge : 64
Enregistré en : décembre 2017
Localisation : Furtif je suis.
Contact :

#8 Message par F6FCO » jeu. 14 déc. 2017 13:46

Merci, ce forum est un régal :-D
Commandé 5 16f88 sur Ebay, en attendant je continue donc mes cours en utilisant le simulateur interne. Autre question: les Pickit3 qu'on trouve à 9€ chez les chinois ont-ils les mêmes possibilités que l'authentique ?
Une porte nand prend 2 bits en entrée... cochonne va !!!

Pickit3 et MPlab
satinas
Passioné
Passioné
Messages : 302
Enregistré en : novembre 2015

#9 Message par satinas » jeu. 14 déc. 2017 14:19

J'ai commandé récemment 2 clones Pickit2 et Pickit3, et pas de problèmes avec.
Si tu as les moyens commande l'original, qui est garanti, mais les clones ont l'air de marcher, je vois pas beaucoup de gens s'en plaindre.
Pas de garantie et je pense illégaux, mais le quart du prix ...

Pickit3 et MPlab
F6FCO
Avatar de l’utilisateur
Confirmé
Confirmé
Messages : 516
Âge : 64
Enregistré en : décembre 2017
Localisation : Furtif je suis.
Contact :

#10 Message par F6FCO » jeu. 14 déc. 2017 17:14

J'ai déjà un original, le chinois serait juste en rescue en cas de panne.
satinas a écrit :Si tu as les moyens commande l'original, qui est garanti,

On pourrait avoir une longue discussion sur cette fameuse garantie de Microchips, j'ai eu affaire à eux pour un Dragon en panne (l'équivalent du pickit pour les AVR), çà a duré un an et c'est finalement le vendeur qui a fini par me le remplacer.

Pour l'instant je suis en train de me débattre avec l'effacement de la ram, FSR et INDF :? pas simple.
Une porte nand prend 2 bits en entrée... cochonne va !!!


Retourner vers « Généralités sur les PICs »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités