Bienvenue aux nouveaux arrivants sur FantasPic !

- Pensez à lire les règles durant votre visite, il n'y en a pas beaucoup, mais encore faut-il les respecter .
- N’hésitez pas à faire des remarques et/ou suggestions sur le Forum, dans le but de l'améliorer et de rendre vos prochaines visites plus agréables.
- Vous pouvez regarder votre "panneau de l'utilisateur" afin de configurer vos préférences.
- Un passage par "l'utilisation du forum" est recommandé pour connaître les fonctionnalités du forum.

--- L’équipe FantasPic ---
Tout ce qui n'a pas de catégorie !
Relais statique et moteur
pspic
Passioné
Passioné
Messages : 250
Âge : 72
Enregistré en : septembre 2017
Localisation : 68

#101 Message par pspic » mar. 1 oct. 2019 17:38

Gérard a écrit :concernant mon téléphone, c'est en haut à droite, " petits carrés. en cliquant dessus un menu s'ouvre :

OK merci.

Pour en revenir au programme, j'ai eu les 18F2520, j'en ai programmé un.
Au reset, le LCD affiche bien SUNRISE_SUNSET mais pas l'heure.
J'ai utilisé l'utilitaire pour mettre la RTC à l'heure avec le smartphone.
Où ai-je commis une erreur?


Même si la RTC n'est pas à l'heure l'affichage se fait quand même.
Comme SUNRISE SUNSET s'affichent, le programme s'execute jusqu'au while mais après ne boucle pas avec le wend.
Ca sent un problème de RTC.
Dans un premier temps, retire le HC-06, il n'est utile que pour le mise à jour de la RTC (sur mon prototype j'ai mis un inter qui coupe le +5V qui alimente le HC-06).
Si le programme se plante toujours, il faut revoir le câblage de la RTC.
Tu fais l'essai sur quel type d'outil ? EASY PIC ?
Après il est possible de placer des Leds à différents stades du programme pour voir où ça plante.

Relais statique et moteur
pspic
Passioné
Passioné
Messages : 250
Âge : 72
Enregistré en : septembre 2017
Localisation : 68

#102 Message par pspic » mar. 1 oct. 2019 18:06

Compare ton Project manager avec ci-dessous.
Q1.JPG
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.

Relais statique et moteur
paulfjujo
Avatar de l’utilisateur
Expert
Expert
Messages : 1472
Âge : 69
Enregistré en : juillet 2015
Localisation : 01800
Contact :

#103 Message par paulfjujo » mar. 1 oct. 2019 20:41

bonsoir,

à verifier :
si la RTC est neuve, ou si on change la pile, il faut faire une 1ere init par defaut, avec des valeurs coherentes
et l'activer
j'utilise une entree du PIC,strap ou pas de strap pour cela (entree RTC_Forcee)

Code : Tout sélectionner


 UART1_Write_CText
(" Init RTC DS3231: \r\n");
  I2C1_Init(400000);

  
     UART1_Write_CText
(" Active sortie SQW=1Hz: \r\n");
     write_DS3231(0x0E,0b01000000);    // batterie LIRC2032 4,4V

  if(RTC_Forcee==0)
  {
   UART1_Write_CText( "init valeurs RTC par defaut ");
   write_DS3231(0,0x50); //Reset second to 0 sec. and stop Oscillator
   write_DS3231(1,0x59); //write min
   write_DS3231(2,Dec2Bcd(14)); //write hour
   write_DS3231(3,0x02); //write day of week
   write_DS3231(4,0x01); // write date
   write_DS3231(5,0x05); // write month
   write_DS3231(6,Dec2Bcd(18)); // write year 2014
   }
   else
   
{
       UART1_Write_CText(" Re-Lecture RTC ");
   }
   Display_Date_Time(1) ;
   CRLF1();

r
Aides toi, le ciel ou Fantastpic t'aideras

Relais statique et moteur
Gérard
Avatar de l’utilisateur
Expert
Expert
Messages : 1212
Âge : 61
Enregistré en : septembre 2015
Localisation : Alsace - Haut-Rhin

#104 Message par Gérard » mar. 1 oct. 2019 20:44

J'utilise une "planche à pain" pour les essais.
Je continue demain AM.

La liaison HC05 fonctionne avec ton soft mais je ne sais pas si la RTC est mise à jour.
Le 18 / 04 / 2019 je suis devenu papy de jumeaux, une fille et un garçon. Quel bonheur.

Relais statique et moteur
pspic
Passioné
Passioné
Messages : 250
Âge : 72
Enregistré en : septembre 2017
Localisation : 68

#105 Message par pspic » mer. 2 oct. 2019 08:26

à verifier :
si la RTC est neuve, ou si on change la pile, il faut faire une 1ere init par defaut, avec des valeurs coherentes
et l'activer

Bonjour Paul,
J'avais remarqué qu'avec la RTC DS1307 il fallait faire une init, mais avec la DS3231 ce n'est pas utile.
Je viens de refaire l'essai suivant:
J'enlève la pile de la RTC et je met sous tension, Jour, mois, année se mettent à 1, heure, minute, seconde se mettent à 0 et les secondes s'incrémentent.
Comme ce programme fonctionne chez moi, je pense à un problème de hard.
Modifié en dernier par pspic le mer. 2 oct. 2019 09:09, modifié 1 fois.

Relais statique et moteur
pspic
Passioné
Passioné
Messages : 250
Âge : 72
Enregistré en : septembre 2017
Localisation : 68

#106 Message par pspic » mer. 2 oct. 2019 08:51

La liaison HC05 fonctionne avec ton soft mais je ne sais pas si la RTC est mise à jour.


Comme le programme semble figé, la mise à jour ne peut pas se faire.
Je viens de faire l'essai sans pile dans la RTC, à la mise sous tension l'afficheur affiche 01/01/2000 00:00:01 et les secondes s'incrémentent.
Pour y voir clair, j'ai ajouté une led sur RA2 qui va clignoter tant que le programme passe dans la boucle While Wend.
Manip à faire:
Charger ce Hex
SunRiseSunSet.zip
et vérifier si la led RA2 clignote.
Si la led ne clignote pas il faut chercher coté hard
Quand ce problème sera réglé, tu pourra ouvrir la source avec Mikrobasic et adapter la procédure "ConfigureLocalData" à ta position.
Tu trouvera la source modifiée ici: http://www.grosfichiers.com/6czf4v2Kexi utiliser "Télécharger tout en un"
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.

Relais statique et moteur
pspic
Passioné
Passioné
Messages : 250
Âge : 72
Enregistré en : septembre 2017
Localisation : 68

#107 Message par pspic » jeu. 3 oct. 2019 13:11

Bonjour Gérard,
Encore une question, tu utilises quelles référence et type de pile dans ta RTC ?

Relais statique et moteur
paulfjujo
Avatar de l’utilisateur
Expert
Expert
Messages : 1472
Âge : 69
Enregistré en : juillet 2015
Localisation : 01800
Contact :

#108 Message par paulfjujo » jeu. 3 oct. 2019 21:07

pour info,
j'ai remplacé la pile CR2032 sur mes RTC DS2301 par des LIR2032 qui font 4,1V neuve . :? . bien qu'elle soit bien plus chere!
lorsque mon montage MCU est alimenté en 5V
Aides toi, le ciel ou Fantastpic t'aideras

Relais statique et moteur
Gérard
Avatar de l’utilisateur
Expert
Expert
Messages : 1212
Âge : 61
Enregistré en : septembre 2015
Localisation : Alsace - Haut-Rhin

#109 Message par Gérard » jeu. 3 oct. 2019 23:00

Bonjour à tous,
Tout ce que j'ai essayé n'a pas fonctionné. J'ai mis un mouchard (une LED qui clignote), le programme reste figé et ne veut pas lire la RTC.
C'est vrai que je n'ai pas mis de pile. Est ce que ça peut être le problème?
Habituellement j'utilise des CR2032.

HS ON
Hier soir j'ai eu un souci avec ma chaudière, du coup je n'ai pas avancé aujourd'hui. Demain en vadrouille chez notre fille et les jumeaux, samedi installation du matériel pour un spectacle le soir, dimanche invité chez notre 2e fille.
C'est dur la vie de retraité...
HS OFF
Le 18 / 04 / 2019 je suis devenu papy de jumeaux, une fille et un garçon. Quel bonheur.

Relais statique et moteur
pspic
Passioné
Passioné
Messages : 250
Âge : 72
Enregistré en : septembre 2017
Localisation : 68

#110 Message par pspic » ven. 4 oct. 2019 07:23

paulfjujo a écrit :pour info,
j'ai remplacé la pile CR2032 sur mes RTC DS2301 par des LIR2032 qui font 4,1V neuve . :? . bien qu'elle soit bien plus chere!
lorsque mon montage MCU est alimenté en 5V

Bonjour, je pense que tu voulais dire RTC DS3231 ?
J'utilise une pile CR2032 en supprimant le circuit de charge comme c'est une pile non rechargeable.
Ceci m'oblige de changer la pile de temps en temps.
Concernant la LIR2032 qui est une pile rechargeable j'ai un peu de crainte comme le circuit de charge est rudimentaire.
Modif_CR2032.JPG
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.


Retourner vers « Coin Fourre-tout »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité