Bienvenue aux nouveaux arrivants sur FantasPic !

- Pensez à lire les règles durant votre visite, il n'y en a pas beaucoup, mais encore faut-il les respecter .
- N’hésitez pas à faire des remarques et/ou suggestions sur le Forum, dans le but de l'améliorer et de rendre vos prochaines visites plus agréables.
- Vous pouvez regarder votre "panneau de l'utilisateur" afin de configurer vos préférences.
- Un passage par "l'utilisation du forum" est recommandé pour connaître les fonctionnalités du forum.

--- L’équipe FantasPic ---
Tout ce qui n'a pas de catégorie !
HC05 et HC06
Gérard
Avatar de l’utilisateur
Expert
Expert
Messages : 1068
Âge : 60
Enregistré en : septembre 2015
Localisation : Alsace - Haut-Rhin

#121 Message par Gérard » mar. 9 avr. 2019 16:42

Bonjour à tous,

Test_HC06.PNG


Voilà le résultat d'un test HC06. Le câblage est conforme à ce que tu as demandé Pspic. Par contre, la vitesse est de 9600. Avec 38400, pas de liaison PC/HC.

J'ai envoyé 2x chaque commande, version, role et name.
Comment obtiens-tu le texte en vert sur ta copie d'écran?

EDIT :
j'ai trouvé cette page
J'ai changé le nom de mon HC05 et CA MARCHE ....
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.
Le 18 / 04 / 2019 je suis devenu papy de jumeaux, une fille et un garçon. Quel bonheur.

HC05 et HC06
pspic
Amateur
Amateur
Messages : 143
Âge : 72
Enregistré en : septembre 2017
Localisation : 68

#122 Message par pspic » mar. 9 avr. 2019 19:40

Bonsoir Gérard et tous les autres,
Bonne nouvelle, je savais que tes HC05 ne resterai pas éternellement muet.
Voilà le résultat d'un test HC06

Je pense que tu voulais dire HC05 ?
Comment obtiens-tu le texte en vert sur ta copie d'écran?

Onglet Display et cocher la case Half duplex.

Ci-joint un nouvel outil pour rechercher les configurations des HCs, pour ceux qui veulent le tester.
Test_Hc.zip


Test HC05:
Im_Test_Hc5.JPG


Test HC06:
Im_Test_Hc6.JPG
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.

HC05 et HC06
venom
Avatar de l’utilisateur
Confirmé
Confirmé
Messages : 583
Âge : 33
Enregistré en : avril 2016
Localisation : Klyntar
Contact :

#123 Message par venom » mar. 9 avr. 2019 20:56

Cool pour Gérard. 8-)

@pspic je testerai a l'occase et te ferai mon rapport :wink:






@++
En fait tout est une question de BIT ? :-D

HC05 et HC06
Jérémy
Administrateur du site
Administrateur du site
Messages : 2310
Âge : 40
Enregistré en : juillet 2015
Localisation : Dans le sud
Contact :

#124 Message par Jérémy » mar. 9 avr. 2019 21:02

Bonne nouvelle ca !

Bravo à tous pour votre persévérance
C'est en faisant des erreurs, que l'on apprend le mieux !!!

HC05 et HC06
venom
Avatar de l’utilisateur
Confirmé
Confirmé
Messages : 583
Âge : 33
Enregistré en : avril 2016
Localisation : Klyntar
Contact :

#125 Message par venom » mar. 9 avr. 2019 22:03

Jérémy a écrit :Bonne nouvelle ca !

Bravo à tous pour votre persévérance


C'est clair 13 pages c'est pas rien exit






@++
En fait tout est une question de BIT ? :-D

HC05 et HC06
Gérard
Avatar de l’utilisateur
Expert
Expert
Messages : 1068
Âge : 60
Enregistré en : septembre 2015
Localisation : Alsace - Haut-Rhin

#126 Message par Gérard » mer. 10 avr. 2019 17:06

Bonjour,
Tests fait sur les 4 modules.
Les HC05 répondent à 38400
Les HC06 répondent à 9600
J'ai coché CRLF pour tous les modules sinon pas de réponse.
Un des 2 HC06 répond HC06-2C14

Le petit soft est OK. Je ne sais pas comment certains modules répondent à 38400. Est ce que c'est par défaut?

En tous cas, ils fonctionnent et j'arrive à m'en servir grâce à vous tous. Un grand Merci !
Le 18 / 04 / 2019 je suis devenu papy de jumeaux, une fille et un garçon. Quel bonheur.

HC05 et HC06
Gérard
Avatar de l’utilisateur
Expert
Expert
Messages : 1068
Âge : 60
Enregistré en : septembre 2015
Localisation : Alsace - Haut-Rhin

#127 Message par Gérard » mer. 10 avr. 2019 17:06

venom a écrit :
Jérémy a écrit :Bonne nouvelle ca !

Bravo à tous pour votre persévérance


C'est clair 13 pages c'est pas rien exit






@++



Et ce n'est pas fini... :-D
Le 18 / 04 / 2019 je suis devenu papy de jumeaux, une fille et un garçon. Quel bonheur.

HC05 et HC06
venom
Avatar de l’utilisateur
Confirmé
Confirmé
Messages : 583
Âge : 33
Enregistré en : avril 2016
Localisation : Klyntar
Contact :

#128 Message par venom » mer. 10 avr. 2019 18:48

@pspic

Chez moi ton logiciel ne renvoie rien :sad:
Tu configure ta fenêtre setup comment pour un HC-05 ? Tu programme sur quel compilateur ?
Sans titre.png







@++
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.
En fait tout est une question de BIT ? :-D

HC05 et HC06
pspic
Amateur
Amateur
Messages : 143
Âge : 72
Enregistré en : septembre 2017
Localisation : 68

#129 Message par pspic » mer. 10 avr. 2019 20:03

Bonjour Venom,
Merci pour ton essai.
L'essentiel est le port Com, le baud rate n'est pas utile.
J'ai fais un rapide résumé avec le document ci-joint.
Je développe avec Delphi et la librairie Comport pour la Com.
Tu utilises quel interface entre le PC et le module HC ?
Tu mets bien la pin EN du HC à +5V ?

Descriptif_Test_Hc.doc


Setup.JPG
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.
Modifié en dernier par pspic le mer. 10 avr. 2019 20:35, modifié 1 fois.

HC05 et HC06
pspic
Amateur
Amateur
Messages : 143
Âge : 72
Enregistré en : septembre 2017
Localisation : 68

#130 Message par pspic » mer. 10 avr. 2019 20:17

Gérard a écrit :Le petit soft est OK. Je ne sais pas comment certains modules répondent à 38400. Est ce que c'est par défaut?


Bonjour Gérard,
La réponse n'est ni plus ni moins que le baud rate configuré dans le module.
Si tu change le baud rate c'est ce dernier qui va être trouvé.
Il semble que les HC05 sont livrés avec un baud rate de 38400 et les HC06 avec 9600.
Voir le descriptif_Test_Hc.doc dans le post précédent.


Retourner vers « Coin Fourre-tout »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 6 invités