Bienvenue aux nouveaux arrivants sur FantasPic !

- Pensez à lire les règles durant votre visite, il n'y en a pas beaucoup, mais encore faut-il les respecter .
- N’hésitez pas à faire des remarques et/ou suggestions sur le Forum, dans le but de l'améliorer et de rendre vos prochaines visites plus agréables.
- Vous pouvez regarder votre "panneau de l'utilisateur" afin de configurer vos préférences.
- Un passage par "l'utilisation du forum" est recommandé pour connaître les fonctionnalités du forum.

--- L’équipe FantasPic ---
Forum général sur l'Assembleur !

Modérateur : mazertoc

soucis avec DS1621
JJE
Passioné
Passioné
Messages : 331
Âge : 78
Enregistré en : novembre 2017
Localisation : Picardie

#1 Message par JJE » lun. 20 mai 2019 16:44 lien vers la Data-Sheet : Cliquez ici

Bonjour à tous,
quelqu'un a-t-il quelque expérience sur ce circuit capteur de température ?
Le programme de test que j'essaye de mettre au point et qui, par ailleurs ma pose d'autres soucis voir ici me retourne toujours 0xc400 quand je fais une lecture de la température courante (en mode OneShot ou pas). C'est d'autant plus étonnant que cette température (-60° en décimal) est hors d'atteinte le datasheet disant
Measures Temperatures From -55°C to +125°C in 0.5°C Increments. Fahrenheit Equivalent is -67°F to 257°F in 0.9°F Increments
Cordialement

JJE

C'est pas parcequ'on n'a rien à dire qu'il faut fermer sa G....e

soucis avec DS1621
paulfjujo
Avatar de l’utilisateur
Expert
Expert
Messages : 1307
Âge : 68
Enregistré en : juillet 2015
Localisation : 01800
Contact :

#2 Message par paulfjujo » lun. 20 mai 2019 20:30 lien vers la Data-Sheet : Cliquez ici

bonsoir,


si cela peut t'aider .. du temps ou je pratiquais l'asm
Aides toi, le ciel ou Fantastpic t'aideras

soucis avec DS1621
JJE
Passioné
Passioné
Messages : 331
Âge : 78
Enregistré en : novembre 2017
Localisation : Picardie

#3 Message par JJE » mar. 21 mai 2019 17:41 lien vers la Data-Sheet : Cliquez ici

Merci paulfjujo, j'aurais dû penser à faire un tour sur ton site, mine d'info :-D
j'ai vraiment l'impression de faire les mêmes choses que toi, en utilisant les facilités de disposer d'un port I2C sur le pic mis en oeuvre.
Je me pose deux questions sur ton source :
1 :

Code : Tout sélectionner

DELAY_SHORT:        ; provides nominal 25 usec delay
    MOVLW .20
    MOVWF LOOP2
DELAY_SHORT_1
:
    NOP
    DECFSZ LOOP2
, F
    GOTO DELAY_SHORT_1
    RETURN     

j'arrive plutôt à 86 us (à 4MH)
2 :
la séquence

Code : Tout sélectionner

    CALL    OUT_BYTE
    CALL    NACK

est systématique, ne suffirait-il pas de faire précéder le return du OUT_BYTE de

Code : Tout sélectionner

    NOP
    NOP
    CALL CLOCK_PULSE
    NOP

Cette affaire étant très ancienne pour toi, je ne t'en voudrai pas si tu ne prends pas le temps d'y répondre.
Cordialement

JJE

C'est pas parcequ'on n'a rien à dire qu'il faut fermer sa G....e


Retourner vers « Langage ASM »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 5 invités