Bienvenue aux nouveaux arrivants sur FantasPic !

- Pensez à lire les règles durant votre visite, il n'y en a pas beaucoup, mais encore faut-il les respecter .
- N’hésitez pas à faire des remarques et/ou suggestions sur le Forum, dans le but de l'améliorer et de rendre vos prochaines visites plus agréables.
- Vous pouvez regarder votre "panneau de l'utilisateur" afin de configurer vos préférences.
- Un passage par "l'utilisation du forum" est recommandé pour connaître les fonctionnalités du forum.

--- L’équipe FantasPic ---
Forum général sur l'Assembleur !

Modérateur : mazertoc

soucis avec PicKit3
JJE
Passioné
Passioné
Messages : 357
Âge : 78
Enregistré en : novembre 2017
Localisation : Picardie

#1 Message par JJE » mar. 26 mars 2019 06:20

Bonjour à tous,
Devant les limites de MPLAB SIM pour ce que je suis en train de faire (exploiter un périphérique I2C), j'ai cherché à mettre en service un PicKit 3 (officiel) que j'ai depuis un moment.
Quand je le sélectionne comme programmateur, j'obtiens le message suivant :
PICkit 3 detected
Connecting to PICkit 3...
Firmware Suite Version...... 01.28.90
Firmware type......................Midrange
PICkit 3 Connected.
Target Detected
Target Device ID (00000000) does not match expected Device
ID (00002040).


Les deux dernières lignes en un rouge très impressionnant.
Mes connexions et alimentations ne semblent pas en cause puisque le Target est detected :-D

Puis-je continuer sans tenir compte de ce message ?
Merci
Cordialement

JJE

C'est pas parcequ'on n'a rien à dire qu'il faut fermer sa G....e

soucis avec PicKit3
paulfjujo
Avatar de l’utilisateur
Expert
Expert
Messages : 1486
Âge : 69
Enregistré en : juillet 2015
Localisation : 01800
Contact :

#2 Message par paulfjujo » mar. 26 mars 2019 09:22

bonjour,

ton firmware date un peu ...

as-tu declaré un type de device (reference MCU)
et connecté celui ci sur l'ISCSP du pickit3

uniquement pickit3 (RPC) connecté sur l'USB
j'obtiens uniquement le message Pickit3 connected
avec la version Pickit3 standalone Pickit3 3.10

pickit3_version.jpg


maintenant j'utilise plutot MPLABX IPE avec un Pickit4 ..
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.
Aides toi, le ciel ou Fantastpic t'aideras

soucis avec PicKit3
JJE
Passioné
Passioné
Messages : 357
Âge : 78
Enregistré en : novembre 2017
Localisation : Picardie

#3 Message par JJE » jeu. 28 mars 2019 19:06

bonsoir paulfjujo,
merci de t'être intéressé à mon soucis.
je ne trouve aucun moyen de mettre à jour le firmware de mon PicKit3 :roll:
les pages que je trouve me renvoient toujours à MPLAB X
Cordialement

JJE

C'est pas parcequ'on n'a rien à dire qu'il faut fermer sa G....e

soucis avec PicKit3
paulfjujo
Avatar de l’utilisateur
Expert
Expert
Messages : 1486
Âge : 69
Enregistré en : juillet 2015
Localisation : 01800
Contact :

#4 Message par paulfjujo » lun. 1 avr. 2019 10:47

bonjour,

Effectivement , il faut passer par MPLABX IDE V5.15
ouvrir un projet quelconque et passer par :
Productione
Set project Configuration
Customise
sélectionner pickit3
puis Conf Default
choisir pickit3
et naviguer dans les options
jusqu'à Firmware .. decocher , et choisir le fichier JAM

nota:
j'ai un ERTAZT de Pickit3 , l'original cramé par injection de 12V !)
avec certains PIC , ex: 18F26K22) je suis obligé de diminuer le VDD fournit par Pickit3 de 5,00V à 3,6V
pour arriver à finaliser le chargement (par Verif OK).
le PIC etant TOUT SEUL sur un support ZIF ! pourtant le pickit est sensé pouvoir sortir 50mA maxi ( fusible PCT1=50mA)
3,6V ce serait plutot pour un 18LF26K22 !

je joins le fichier Pickit3.jar qui contient le JAM .. zipé en fin de liste
mais je ne sais pas comment l'exploiter en dehors de MPLABX

c'est mieux en images :
MAJ_pickit3_a.jpg


MAJ_pickit3_b.jpg


MAJ_pickit3_c.jpg


MAJ_pickit3_d.jpg


si le pickit3 doit alimenter le MCU
Pickit3_power_the_circuit.jpg


PICKIT3_jar.zip
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.
Aides toi, le ciel ou Fantastpic t'aideras

soucis avec PicKit3
JJE
Passioné
Passioné
Messages : 357
Âge : 78
Enregistré en : novembre 2017
Localisation : Picardie

#5 Message par JJE » lun. 1 avr. 2019 19:08

bonsoir paulfjujo,
merci de me consacrer tout ce temps, on dirait que chez Microchip, MPLAB est oublié au profit de MPLABX. J'ai tenté une fois de m'y mettre, il ne m'a pas semblé bien sympa pour l'assembleur, peut-être faudrait-il que j'insiste.
Encore merci, je tente la manipulation demain car MPLABSIM a vraiment des limites
Cordialement

JJE

C'est pas parcequ'on n'a rien à dire qu'il faut fermer sa G....e

soucis avec PicKit3
satinas
Passioné
Passioné
Messages : 420
Enregistré en : novembre 2015

#6 Message par satinas » lun. 1 avr. 2019 21:24

Bonsoir,

C'est quel type de pic qui pose problème ?
La version 01.28.90 du PicKit3 est bien celle qui s'installe avec la dernière version de MpLab, la 8.92
Tu peux vérifier MpLab en relançant l'installation et en sélectionnant "repair".

Paul tu arrives à utiliser sur MpLab un PicKit3 updaté par MpLabX au préalable, c'est bien ça ?

soucis avec PicKit3
JJE
Passioné
Passioné
Messages : 357
Âge : 78
Enregistré en : novembre 2017
Localisation : Picardie

#7 Message par JJE » mar. 2 avr. 2019 07:22

bonjour Satinas, j'utilise un PIC16f884
Cordialement

JJE

C'est pas parcequ'on n'a rien à dire qu'il faut fermer sa G....e

soucis avec PicKit3
JJE
Passioné
Passioné
Messages : 357
Âge : 78
Enregistré en : novembre 2017
Localisation : Picardie

#8 Message par JJE » mar. 2 avr. 2019 07:26

Ma vieille machine tourne toujours sous Windows XP et MPLABX ne semble pas trop apprécier :cry:
Je n'ai pas réussi la manipe proposée par Paul.
Cordialement

JJE

C'est pas parcequ'on n'a rien à dire qu'il faut fermer sa G....e

soucis avec PicKit3
satinas
Passioné
Passioné
Messages : 420
Enregistré en : novembre 2015

#9 Message par satinas » mar. 2 avr. 2019 08:55

Bonjour,

Cela devrait marcher, le 16F884 a bien un device id 0x2040, c'est un vieux pic reconnu par les PicKit2 et PicKit3.
Le fait qu'il trouve une id 0x0000 correspond sans doute à un problème de connexion (pas d'inversion PGC/PGD).
Essaie d'autres types de pic si tu utilises pour la première fois ce programmateur.

https://www.microchip.com/forums/downlo ... e=0;901120

soucis avec PicKit3
paulfjujo
Avatar de l’utilisateur
Expert
Expert
Messages : 1486
Âge : 69
Enregistré en : juillet 2015
Localisation : 01800
Contact :

#10 Message par paulfjujo » mar. 2 avr. 2019 12:23

bonjour,

satinas a écrit :....
Paul tu arrives à utiliser sur MpLab un PicKit3 updaté par MpLabX au préalable, c'est bien ça ?


j'ai bien effectué cette operation de mise à jour,
mais je n'en vois pas trace dans le resultat de "ABOUT" avec la version standalone Pickit3.exe
je pensais pouvoir y trouver l'extension du fichier JAM 015501..
sur les vieilles version Pickit3 on voyait en clair le nom du fichier JAM

Picki3_Version_190402.jpg


nota: c'est une version pickit3 RPC que j'ai maintenant
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.
Aides toi, le ciel ou Fantastpic t'aideras


Retourner vers « Langage ASM »

Qui est en ligne

Utilisateurs parcourant ce forum : MSN [Bot] et 2 invités