Bienvenue aux nouveaux arrivants sur FantasPic !

- Pensez à lire les règles durant votre visite, il n'y en a pas beaucoup, mais encore faut-il les respecter .
- N’hésitez pas à faire des remarques et/ou suggestions sur le Forum, dans le but de l'améliorer et de rendre vos prochaines visites plus agréables.
- Vous pouvez regarder votre "panneau de l'utilisateur" afin de configurer vos préférences.
- Un passage par "l'utilisation du forum" est recommandé pour connaître les fonctionnalités du forum.

--- L’équipe FantasPic ---
Forum général sur l'Assembleur !

Modérateur : mazertoc

soucis avec l'assembleur
JJE
Amateur
Amateur
Messages : 122
Âge : 78
Enregistré en : novembre 2017
Localisation : Picardie

#1 Message par JJE » mar. 16 janv. 2018 11:56 lien vers la Data-Sheet : Cliquez ici

Bonjour,
Je souhaite vérifier qu'un segment de code se trouve à l'intérieur d'une même page (sur un 16F88).
Sur le code suivant :

Code : Tout sélectionner

;.../... du code précède
AV_Debut
AV_PageDebut set AV_Debut 
& 0xF800
; .../... mon code
AV_Fin
AV_PageFin  set AV_Fin 
& 0xF800
    if AV_PageDebut 
^ AV_PageFin != 0
        error 
"Les sous-programmes AV_xx doivent être dans la même page de code
    endif
; .../... du code suit

L'assembleur me répond :
Error[151] E:\DOCUMENTS DE JJ\MES PROJETS MPLAB\MON_HORLOGE\AFFICHAGE ECRAN\DEUXIèME éTAPE\PROGRAMMES\TEST AV0820\TEST AV0820.ASM 198 : Operand contains unresolvable labels or is too complex
Error[151] E:\DOCUMENTS DE JJ\MES PROJETS MPLAB\MON_HORLOGE\AFFICHAGE ECRAN\DEUXIèME éTAPE\PROGRAMMES\TEST AV0820\TEST AV0820.ASM 541 : Operand contains unresolvable labels or is too complex

Quelqu'un peut-il me dire ce que AV_Debut & 0xF800 a de trop compliqué.
j'ai même essayé

Code : Tout sélectionner


AV_PageDebut set high
(AV_Debut) & 0xF8

avec le même insuccès.

Cordialement
JJE

soucis avec l'assembleur
satinas
Passioné
Passioné
Messages : 267
Enregistré en : novembre 2015

#2 Message par satinas » mar. 16 janv. 2018 13:25 lien vers la Data-Sheet : Cliquez ici

Bonjour JJE,

Dans le menu "Project/Build_Options/Project/MPASM suite" si l'option "Generate relocatable code" est cochée, décoche la et coche "Generate absolute code"

soucis avec l'assembleur
JJE
Amateur
Amateur
Messages : 122
Âge : 78
Enregistré en : novembre 2017
Localisation : Picardie

#3 Message par JJE » jeu. 18 janv. 2018 19:13 lien vers la Data-Sheet : Cliquez ici

merci satinas, je ne trouve ton post que ce soir, mais ton conseil est très judicieux et de plus très compréhensible :?
JJE


Retourner vers « Langage ASM »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités