Bienvenue aux nouveaux arrivants sur FantasPic !

- Pensez à lire les règles durant votre visite, il n'y en a pas beaucoup, mais encore faut-il les respecter .
- N’hésitez pas à faire des remarques et/ou suggestions sur le Forum, dans le but de l'améliorer et de rendre vos prochaines visites plus agréables.
- Vous pouvez regarder votre "panneau de l'utilisateur" afin de configurer vos préférences.
- Un passage par "l'utilisation du forum" est recommandé pour connaître les fonctionnalités du forum.

--- L’équipe FantasPic ---
Forum général sur le langage C !

Modérateur : Jérémy

encore un piege à ions , police de caratere
paulfjujo
Avatar de l’utilisateur
Expert
Expert
Messages : 1502
Âge : 69
Enregistré en : juillet 2015
Localisation : 01800
Contact :

#1 Message par paulfjujo » mar. 20 août 2019 18:43

bonsoir,

:cry: J'ai le chic pour tomber sur des cas libidineux ...

"cl1" et "c11" apparaissent bien distinctement dans cette fenetre de Fantaspic,
or j'ai galéré pour retrouver des erreurs signalées à la compilation comme erreur : variable non déclarée

en regardant la fenetre "messages" je vois 'd1'
que vient faire ce nom de variable avec c11 ?
je cherche .. rien trouvé??

j'ai meme décomposé un morceau de code en hexadecimal
c11=c11+'0';
02020206331313D6331312B2730273B0D0A
c 1 1 = c 1 1 + ' 0 ' ;
c'est bien c11 ! au moins à cet endroit de programme

j'etais sur d'avoir tapé c11 et non pas cl1 comme nom de variable
le L etant loin du 1 sur le clavier.
Mais comme c'était une adaptation d'un programme existant , cl1 devait etre utilisé ailleurs au lieu de c11.

En fait , c'est un probleme lié surtout dû à la police (fonte) utilisée
car pour ma part , impossible de dissocier CL1 et C11 en minuscule dans l'editeur MikroC. (voir capture d'ecran)
j'ai donc demandé à MikroC , comment changer de police ou fonte dans l'editeur, car
meme dans TOOLS -> EDIT je n'ai rien vu permettant un choix de police.

en Zoomant la fenetre "Message" on peut à peine deviner cl1 au lieu de d1 !
.. je dois penser au binoculaire ou ecran geant 2Mx3M !

cl1 et c11 apparaissent-ils bien distinctement sur vos ecran MikroC ? ou MikroBasic ou Pascal ?
ou est-ce mon windows10 ?

MikroC_problemo_c11_c12_b.jpg


il en est de meme pour le choix de couleur pour le texte des librairies annexes
:furieux: on est pas aidés, nous les bigleux !


MikroC_color_library.jpg
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.
Aides toi, le ciel ou Fantastpic t'aideras

encore un piege à ions , police de caratere
Gérard
Avatar de l’utilisateur
Expert
Expert
Messages : 1212
Âge : 61
Enregistré en : septembre 2015
Localisation : Alsace - Haut-Rhin

#2 Message par Gérard » mar. 20 août 2019 20:48

Capture d’écran 2019-08-20 à 20.46.03.png


Pas terrible effectivement.
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.
Le 18 / 04 / 2019 je suis devenu papy de jumeaux, une fille et un garçon. Quel bonheur.

encore un piege à ions , police de caratere
paulfjujo
Avatar de l’utilisateur
Expert
Expert
Messages : 1502
Âge : 69
Enregistré en : juillet 2015
Localisation : 01800
Contact :

#3 Message par paulfjujo » mer. 21 août 2019 14:57

Gérard a écrit :Capture d’écran 2019-08-20 à 20.46.03.png

Pas terrible effectivement.



Là, je vois distinctement les 2 noms de variables.. NO Problemo
mais comment les vois-tu dans l'editeur MikroC ?

(j'ai mis un morceau de capture d'ecran editeur dans l'image precedement postée, pour montrer comment elles apparaissent sur mon PC )
Aides toi, le ciel ou Fantastpic t'aideras

encore un piege à ions , police de caratere
Gérard
Avatar de l’utilisateur
Expert
Expert
Messages : 1212
Âge : 61
Enregistré en : septembre 2015
Localisation : Alsace - Haut-Rhin

#4 Message par Gérard » mer. 21 août 2019 15:53

C'est dans View, Code explorer que j'ai fait la copie d'écran.
Le 18 / 04 / 2019 je suis devenu papy de jumeaux, une fille et un garçon. Quel bonheur.

encore un piege à ions , police de caratere
paulfjujo
Avatar de l’utilisateur
Expert
Expert
Messages : 1502
Âge : 69
Enregistré en : juillet 2015
Localisation : 01800
Contact :

#5 Message par paulfjujo » mer. 21 août 2019 16:11

j'ai eu une reponse de MikroE:

You can change the Editor font in the Options->Editor Settings->Open options dialog->Font.



effectivement c'etait plus loin dans l'arborescence ..

j'ai donc modifié le nom de la fonte utilisée dans l'editeur MikroC
suite à ce test comparatif
et captures d'ecran à chaque etape

MikroC_Editor_Fontes_test_190821.jpg


fonte Source Code Pro


MikroC_Editor_Fonte_choisie_190821.jpg


:sifflotte: Là , je distingue mieux les 2 noms de variaibles.. et la taille est un peu plus grande
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.
Aides toi, le ciel ou Fantastpic t'aideras

encore un piege à ions , police de caratere
Gérard
Avatar de l’utilisateur
Expert
Expert
Messages : 1212
Âge : 61
Enregistré en : septembre 2015
Localisation : Alsace - Haut-Rhin

#6 Message par Gérard » mer. 21 août 2019 16:37

Faut être perspicace pour trouver.
En plus tout est en anglais... :oops:
Le 18 / 04 / 2019 je suis devenu papy de jumeaux, une fille et un garçon. Quel bonheur.

encore un piege à ions , police de caratere
Jérémy
Administrateur du site
Administrateur du site
Messages : 2371
Âge : 40
Enregistré en : juillet 2015
Localisation : Dans le sud
Contact :

#7 Message par Jérémy » jeu. 22 août 2019 07:16

Bonjour ,

Zut j'arrive un peu tard sur ce post , car j'avais la solution. Je modifie moi aussi la police de caractères de mikroC .
C'est en faisant des erreurs, que l'on apprend le mieux !!!


Retourner vers « Langage C »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité