Bienvenue aux nouveaux arrivants sur FantasPic !

- Pensez à lire les règles durant votre visite, il n'y en a pas beaucoup, mais encore faut-il les respecter .
- N’hésitez pas à faire des remarques et/ou suggestions sur le Forum, dans le but de l'améliorer et de rendre vos prochaines visites plus agréables.
- Vous pouvez regarder votre "panneau de l'utilisateur" afin de configurer vos préférences.
- Un passage par "l'utilisation du forum" est recommandé pour connaître les fonctionnalités du forum.

--- L’équipe FantasPic ---
Forum général sur le langage C !

Modérateur : Jérémy

[RESOLU] UART Write Text erreur !
pspic
Débutant
Débutant
Messages : 30
Âge : 71
Enregistré en : septembre 2017
Localisation : 68

#41 Message par pspic » ven. 9 mars 2018 13:50 lien vers la Data-Sheet : Cliquez ici

Ce que je ne comprend pas, l'Uart envoi des trames erronées, ceci prouve que le programme boucle et pourtant la led reste fixe.
Peux tu refaire un dernier essai avec les 2 PICs:
Dézipe le Hex ci-joint.
Ouvre MikroProg Suite.
Bouton Erase
Bouton Load le fichier Hex ci-joint.
Bouton Write

MyProject.zip
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.

[RESOLU] UART Write Text erreur !
venom
Avatar de l’utilisateur
Passioné
Passioné
Messages : 372
Âge : 32
Enregistré en : avril 2016
Localisation : . <------ ici
Contact :

#42 Message par venom » ven. 9 mars 2018 15:40 lien vers la Data-Sheet : Cliquez ici

J'ai mis ton .hex dans mes 2 pics,

Bouton Erase
Bouton Load le fichier Hex ci-joint.
Bouton Write


Avec le pic fonctionnel : la led ne clignote pas et je reçois essai
Avec le pic non fonctionnel : la led ne clignote pas et je reçois des hiéroglyphe :-D

Laisse pas gave l'UART ne veut pas. Ce pic est une tête de mule. :mur:
Après par contre je n'ai pas pensé a essayer la fonction TX :sifflotte:

Mais bon les entrées / sorties fonctionnent je lui trouverai bien une utilitée ou au vu du prix. :lol:






@++
En fait tout est une question de BIT ? :-D

[RESOLU] UART Write Text erreur !
cyril13110
Passioné
Passioné
Messages : 475
Âge : 36
Enregistré en : avril 2016
Localisation : 13

#43 Message par cyril13110 » ven. 9 mars 2018 17:32 lien vers la Data-Sheet : Cliquez ici

arf apres si ta un mail pro tu peux en avoir gratos des pic.....

[RESOLU] UART Write Text erreur !
pspic
Débutant
Débutant
Messages : 30
Âge : 71
Enregistré en : septembre 2017
Localisation : 68

#44 Message par pspic » ven. 9 mars 2018 19:31 lien vers la Data-Sheet : Cliquez ici

venom a écrit :J'ai mis ton .hex dans mes 2 pics,

Bouton Erase
Bouton Load le fichier Hex ci-joint.
Bouton Write


Avec le pic fonctionnel : la led ne clignote pas et je reçois essai
Avec le pic non fonctionnel : la led ne clignote pas et je reçois des hiéroglyphe :-D

Laisse pas gave l'UART ne veut pas. Ce pic est une tête de mule. :mur:
Après par contre je n'ai pas pensé a essayer la fonction TX :sifflotte:

Mais bon les entrées / sorties fonctionnent je lui trouverai bien une utilitée ou au vu du prix. :lol:
@++

Une affaire de fou !
Comme ce code fonctionne sur un PIC, nous pouvons conclure que l'autre PIC est HS.
Par contre chez moi la sortie RA2 (broche 4 du PIC) se met à 1 pour 1s, puis à 0 pour 1 s. et ainsi de suite.

[RESOLU] UART Write Text erreur !
venom
Avatar de l’utilisateur
Passioné
Passioné
Messages : 372
Âge : 32
Enregistré en : avril 2016
Localisation : . <------ ici
Contact :

#45 Message par venom » ven. 9 mars 2018 21:29 lien vers la Data-Sheet : Cliquez ici

Ah étrange car avec d'autre code la led clignote bien. Pas grave je lui trouverai bien une petite utilité :razz:
Merci de ton aide






@++
En fait tout est une question de BIT ? :-D


Retourner vers « Langage C »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 5 invités