Bienvenue aux nouveaux arrivants sur FantasPic !

- Pensez à lire les règles durant votre visite, il n'y en a pas beaucoup, mais encore faut-il les respecter .
- N’hésitez pas à faire des remarques et/ou suggestions sur le Forum, dans le but de l'améliorer et de rendre vos prochaines visites plus agréables.
- Vous pouvez regarder votre "panneau de l'utilisateur" afin de configurer vos préférences.
- Un passage par "l'utilisation du forum" est recommandé pour connaître les fonctionnalités du forum.

--- L’équipe FantasPic ---
Forum général sur le langage C !

Modérateur : Jérémy

Ecran Easy TFT
Guest
Confirmé
Confirmé
Messages : 800
Enregistré en : mars 2017

#101 Message par Guest » dim. 8 nov. 2015 17:19

oui mais le contrôleur était en mode dodo NON ?

Ecran Easy TFT
Jérémy
Administrateur du site
Administrateur du site
Messages : 2124
Âge : 39
Enregistré en : juillet 2015
Localisation : Dans le sud
Contact :

#102 Message par Jérémy » dim. 8 nov. 2015 17:20

Non apres le RESET j'effectue desuite un sleep out
C'est en faisant des erreurs, que l'on apprend le mieux !!!

Ecran Easy TFT
Guest
Confirmé
Confirmé
Messages : 800
Enregistré en : mars 2017

#103 Message par Guest » dim. 8 nov. 2015 17:24

tu envois tes commandes en mode 8 ou 16bits?
le fait d'envoyer les commande 0x12 0x13 et 0x39 la lecture a changer ?

Ecran Easy TFT
Guest
Confirmé
Confirmé
Messages : 800
Enregistré en : mars 2017

#104 Message par Guest » dim. 8 nov. 2015 17:26

je dis des soneries :-)

Ecran Easy TFT
Jérémy
Administrateur du site
Administrateur du site
Messages : 2124
Âge : 39
Enregistré en : juillet 2015
Localisation : Dans le sud
Contact :

#105 Message par Jérémy » dim. 8 nov. 2015 17:31

tu envois tes commandes en mode 8 ou 16bits?

J'envoie en 8 bits

le fait d'envoyer les commande 0x12 0x13 et 0x39 la lecture a changer ?

NON :oops:
Soit on lit n'importe quoi , soit les commandes ne passent pas on aprle dans le vide . Oui mais pour lire j'ai besoin d'envoyer des commandes ! alors je devrais pas pouvoir lire ?

Aurait on une valeur sure à lire ?

J'essaye d'envoyer en 16bit tout de suite
C'est en faisant des erreurs, que l'on apprend le mieux !!!

Ecran Easy TFT
Jérémy
Administrateur du site
Administrateur du site
Messages : 2124
Âge : 39
Enregistré en : juillet 2015
Localisation : Dans le sud
Contact :

#106 Message par Jérémy » dim. 8 nov. 2015 17:37

Plop , en fait on lit n’importe quoi , je lis la valeur que j'envoie sur le registre .

0x0A = 0b00001010
C'est en faisant des erreurs, que l'on apprend le mieux !!!

Ecran Easy TFT
Guest
Confirmé
Confirmé
Messages : 800
Enregistré en : mars 2017

#107 Message par Guest » dim. 8 nov. 2015 17:44

bon le contrôleur n'est pas actif

regarde ici une source d'inspiration peut-être c'est I2C mais bon https://github.com/watterott/Arduino-Li ... /MI0283QT9

je te souhaite une bonne soirée

Ecran Easy TFT
Jérémy
Administrateur du site
Administrateur du site
Messages : 2124
Âge : 39
Enregistré en : juillet 2015
Localisation : Dans le sud
Contact :

#108 Message par Jérémy » dim. 8 nov. 2015 23:36

J'épluche encore .

Un truc me turlupine , bon si y'en avait qu'un se serait cool .

Mais quand on envoie une commande ? on envoie aucune valeur ? je veut dire par la , en général en determine un registre et on ecrit une valeur dedans ? la on ne fais qu'envoyer une seul valeurs. Comment il sait ce qu'il doit faire ?
C'est en faisant des erreurs, que l'on apprend le mieux !!!

Ecran Easy TFT
Jérémy
Administrateur du site
Administrateur du site
Messages : 2124
Âge : 39
Enregistré en : juillet 2015
Localisation : Dans le sud
Contact :

#109 Message par Jérémy » lun. 9 nov. 2015 15:18

Quelle est le niveau logique nécessaire sur les broches DATA ? 5V ou 3.3V ? car je peux alimenter a carte avec les deux tensions ? et elle était alimenté en 3.3V jusqu' a maintenant ?
Donc j'appliquai 3.3V pour un niveau logique haut ! ? était il prit en compte ?
C'est en faisant des erreurs, que l'on apprend le mieux !!!

Ecran Easy TFT
Guest
Confirmé
Confirmé
Messages : 800
Enregistré en : mars 2017

#110 Message par Guest » lun. 9 nov. 2015 17:51

Jérémy a écrit :Quelle est le niveau logique nécessaire sur les broches DATA ? 5V ou 3.3V ? car je peux alimenter a carte avec les deux tensions ? et elle était alimenté en 3.3V jusqu' a maintenant ?
Donc j'appliquai 3.3V pour un niveau logique haut ! ? était il prit en compte ?

OUI et bonsoir

Si tu veux bien on fait un point redonne moi tout ton code celui lorsque on faisait des essais en réception merci


Retourner vers « Langage C »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités